Skip to:
Content
Pages
Categories
Search
Top
Bottom

Page Not Found Error With 1.1

  • Avatar of wordpressfan
    wordpressfan
    Participant

    @wordpressfan

    I’m running the latest trunk of 1.1 with my WPMU 2.8.4a install in a subdirectory. I get “page not found” whenever I click on “blog”, “members”, “groups”, etc.

    I have .htaccess installed and running.

    I didn’t have this problem with 1.03. What’s the solution?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    A few questions:

    • Was BP 1.0.3 running on WPMU 2.8.4a, or did you first upgrade to WPMU 2.8.4a before installing trunk? If so, from which version of WPMU did you upgrade?
    • Are you using a custom theme? If so, what happens when you switch to the default parent/child theme?
    • Do you have any plugins other the BP activated? If so, what happens when you deactivate them all except BP?
    • Do you have a bp-custom.php file in use? If so, what happens when you temporarily remove that file?
    • What errors are you seeing in your server’s log files?

    Avatar of wordpressfan
    wordpressfan
    Participant

    @wordpressfan

    1. BP1.0.3 was previously running on WPMU 2.8.4a.

    2. Using default theme.

    3. No other plugins.

    4. No bp-custom.php in use.

    5. No noticeable errors in error logs.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Okay, so everything is standard issue.

    I had a similar problem when I upgraded one of my development sites to pre1.1. I ended up reinstalling from scratch–both WPMU 2.8.4a and BP trunk. I did a clean install–sort of. First, I deactivated BuddyPress since I planned on using the same DB.

    Then I dragged my wp-config.php and .htaccess files out of the root directory before deleting everything else in the root directory. I reinstalled WPMU just by copying the files back into the empty root. I then put back the wp-config and .htaccess files, logged into WPMU as Site Admin, and reactivated BP and reselected the BP themes.

    My problem went away.

    By the way, if you are running WPMU in a development environment and you selected the subdomain install option for blogs, you will have an issue if you have not set up a wildcard DNS record and have more than the main blog. I had this issue with one of my dev sites.

    What happened was that it threw an error when I upgraded Mu form 2.7.1 to 2.8.4a. It could not properly upgrade any of the test blogs (other than Blog ID 1) since it could not resolve the subdomains. I had not set up a wildcard record for that dev site.

    Avatar of wordpressfan
    wordpressfan
    Participant

    @wordpressfan

    So, what I need to do for the optimum chances of the BP trunk working is the following:

    1. Take wp-config.php and .htaccess out of the root directory

    2. Delete everything in the root directory.

    3. Put WPMU back in the root directory.

    4. Reactivate BP and the BP themes.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    I have no idea what will work for you. I was just detailing what I needed to do.

    If your WPMU and server environment were setup properly to begin with, and you followed the instructions in BuddyPress’ readme.txt file, you should have no issues upgrading. But, for me, I had unknown issues in my original setup environment that caused problems. So, I had to go through the process I tried. It may or may not work for you.

    To do a clean WPMu reinstall, you will want to delete the WPMU install completely–this means everything including the folders. Once reinstalled, you can go grab the most recent BP trunk and manually install before reactivating it.

    Avatar of wordpressfan
    wordpressfan
    Participant

    @wordpressfan

    I think I’ll do a clean reinstall of WPMU and BP, this time not using a subdir for my wpmu site. Thanks for the help.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Sub directory installs of WPMU can be tricky, and hard to trouble-shoot. If you can avoid it, you’re better off. If you can’t, the next best thing would be to install it in a static subdomain, and run a subdirectory type installation.

    http://domain.com

    http://community.domain.com/members

    If that makes sense?

    Avatar of wordpressfan
    wordpressfan
    Participant

    @wordpressfan

    I tried the test.domain.com/subdir, now I’ll just go with domain.com.

    Avatar of Aishaladon
    aishaladon
    Participant

    @aishaladon

    I am having the same problem.

    First when I installed wordpessmu ( Yahoo server)

    I selected subdomain( the first option)

    http://www.yourblog.yoursite.com

    Everything installed, I was given temp password

    But was unable to login

    Re-created database, tested again. Same problem.

    The only way to fix this problem was to install with

    sub directory ( second option)

    http://www.yoursite.com/blog

    So using option two, I was able to login.

    Next I installed buddypress.

    But a the same thing thats going on with others, happens to me.

    members, groups, etc. all those pages are empty and I get page not found error.

    Whats up with that?

    Can someone help soon.

    This is a site for a paying client.

    no other plugins installed.

    no fancy themes.

    I have yet to get that far ( lol)

    site is http://yotroutreach.com

    I am familiar with buddy press, and have it installed on other domains, but they are on dreamhost, and not yahoo. :(

    I love dream host.

    Thanks in advance, Aisha

    p.s.

    I tried fresh installs, new databases, in addition to delete httacess, and wp-config , and re-doing everything.

    that does not work for me either :(

    If you can avoid installing MU in a subdirectory you’re going to skip a lot of headaches.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    @Aishaladon

    Your problems seems nothing related to this topic. Your problem at first point is you didn’t configure wpmu as instructed on readme. Subdomain install requires extra configuration on httpd.conf, and/or which can easily be configured via cpanel if Yahoo has it.

    My suggestion is to use Dreamhost for your client, since you have experience using them.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.