Skip to:
Content
Pages
Categories
Search
Top
Bottom

Permalinks and BP Single with WP 3.0 beta 2

  • Recently installed BP 1.2.3. onto my live site (hosted by Siteground), running WP 3.0 beta. All other WP pages work fine with any kind of permalink settings, but All my BP links return a 404 error, no matter what I do – includes admin bar as well as http://www.mysite.com/members/, http://www.mysite/groups/ etc.
    I had this working fine on my local computer using Xampp, so why does the same plugin, the same WP version, the same Db on the live server not work? If this was a Buddypress 1.2.3 incompatibility with WordPress 3.0 I could understand that, but I cannot figure out why it doesn’t work on my live server. Do I need to change something? Please help.Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Travel-Junkie
    Boris
    Participant

    @travel-junkie

    Well, have you changed the references to your local site in the database to your new site? Mainly, it’s in the options table. Do a search for something like my-site.localhost and change it to my-site.com. Also, try updating the permalink structure, making sure that your htaccess file is writable.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    If the live server doesn’t have mod_rewrite actually working or reading the htaccess file, then no, none of the permalinks work – BuddyPress or not.

    AllowOverride FileInfo Options has to be in the vhost in httpd.conf for the acount.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.