Skip to:
Content
Pages
Categories
Search
Top
Bottom

Permalinkstructure is 'broken' when WordPress is in it's own directory

  • Avatar of Mathias
    Mathias
    Member

    @mathiasschopmans

    hey everyone,

    i just installed buddypress.. have to say it’s pretty easy!

    ..but there is something broken in my permalinkstructure.

    my wordpress installation is a bit more advanced:

    (http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory)

    -wordpress is not in the root; it’s in a subfolder called “cms”

    -(the wp-content folder is in the root and called “content”)

    so my wp-config.php looks like this:

    define('WP_SITEURL', 'http://hidden.url/cms');

    define('WP_HOME', 'http://hidden.url');

    define( 'WP_CONTENT_DIR', '/www/htdocs/hidden.url/content' );

    define( 'WP_CONTENT_URL', WP_HOME . '/content');

    every wordpress related blog link will be generated as expected:

    http://hidden.url/my-category/hello-world/

    http://hidden.url/my-page

    but every buddypress related link looks like this:

    http://hidden.url/cms/activity/

    http://hidden.url/cms/members/

    http://hidden.url/cms/forums/

    when i manually remove the ‘cms’ part from the url it works, too: http://bp.liqq.de/forums/

    is there a clean way to remove the cms/ in the uri?

    i think it’s a bug. just searched the whole buddypress plugin for the ‘generate_rewrite_rules’ hook, but buddypress seem to write them otherwise?

    let me know if i got something wrong!

    cheers,

    mathias

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.