Skip to:
Content
Pages
Categories
Search
Top
Bottom

Phantom Name autofills in Buddypress Registration Form

  • Avatar of PeterHatch
    PeterHatch
    Member

    @peterhatch

    This is spooky!

    The name field on my BP registration form autofills with ANNE PORTER

    Have tried this looking at this on various PC’s and the form comes up with ANNE PORTER prefilled in the name field

    I’m using custom community theme

    Any ideas?

    Pete

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    look in the sidebar.php code and see if there is placeholder=”” in the form

    It might have got included in the custom theme. Usually this has username and password in those spots. Also if someone on a computer saves that to the browser you have to delete cookies and settings to remove it. How to depends on the browser.

    Avatar of PeterHatch
    PeterHatch
    Member

    @peterhatch

    thanks @modemlooper

    its the registration form not the login that autofills

    i reckon it must be a cookie issue – a cookie that remembers what you have put in each box so that if it flags up an incorrect entry you don’t have to start over again

    somehow it has written the cookie to my server?

    i’ve tracked the member that caused the problem – joined 8 days ago – but am unlikely to find out what she did to screw the works

    Avatar of PeterHatch
    PeterHatch
    Member

    @peterhatch

    one futher clue is that I found the firstname second name field on my admin profile had been changed to ANNE and PORTER

    Avatar of JaredGoyette
    JaredGoyette
    Member

    @jaredgoyette

    Peter, did you ever find a solution to this? On my site, every time a new user tries to register, my name is the default, which they have to erase before adding their own. How do I fix this?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    If it’s the same computer you saved the form to cookies. You can delete cookies and empty the cache in browser settings. If you have a computer thats used by many you should turn off the ability for a browser to save usernames and passwords.

    Avatar of PeterHatch
    PeterHatch
    Member

    @peterhatch

    Its not the same computer @modemlooper – somehow the registration form prompts this phantom name – it can’t be a cookie issue – haven’t found a fix yet @jaredgoyette

    Avatar of PeterHatch
    PeterHatch
    Member

    @peterhatch

    I should have said it can’t be a cookie issue unless the cookie is on the server which makes no sense

    Avatar of Josh Frank
    Josh Frank
    Participant

    @iamjoshfrank

    We are experiencing the same issue. “Katrina” is pre-populated in the First Name field on the registration page at our site, http://ugnchicago.com/register.

    It isn’t a local cookie issue; it is showing up across multiple machines, multiple browsers, etc.

    Has anyone come up with an answer?

    Avatar of Josh Frank
    Josh Frank
    Participant

    @iamjoshfrank

    Thanks to Katrina Willis (http://katrinawillis.com), my partner on the UGN site, for figuring out the issue. Here is how she describes the fix:

    “On ugnchicago.com, I finally figured out why my name was displaying in the form field.

    In the SQL database, I was the default user (the user with the id=0), so that made my first name display as a default string when you installed the BuddyPress forms (which populates a default into the field). I went in and manually removed that from the database, so we’re clean!”

    I hope this helps you all. And check out Katrina’s site, while you are at it!

    tagged: @PeterHatch, @modemlooper, @JaredGoyette

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I find this completely odd because BuddyPress does not auto create a username on the registration page from the database. Maybe you have mal-ware or something? Also it could be the browser auto filling.

    I have today the same problem! isn’t a cookie!
    I have the always the name ELIA ROSSI in my REGISTER FORM and other fields es. male, 10-10-1996 (date of birth) etc…
    I go with phpmyadmin into SQL and I delete ELIA ROSSI (ID: 0)

    now there isn’ t ELIA ROSSI in the register form but I have already male, 10-10-1996 etc…

    What Can I do ?

    bp 1.5 wp 3.2.1

    @PeterHatch, @modemlooper, @JaredGoyette, @iamjoshfrank

    p.s. I have 970 members and ELIA ROSSI subscribe only today! why ID: 0 ?

    I see now that if I go in the admin page of site in the FIELDS PROFILE I have the same problem! I have (normal) no name but I have male, 10-10-1996 etc… and I can’ t set any other default value for these fields.

    Anyone resolve ?

    I am having the same issue . If you go to http://4villains.org/register you will see the form partially filled out with information about one of the members A.D. Shanton. This isn’t good because my community is getting confused as well as anxious about security.

    Has anyone found a solution to this?

    Update:
    This issue is more serious then i first thought now several of my community who have been helping me test are not receiving confirmation emails to their email when registering. They had to first remove all the content that was auto filled in our form for registration ( which is info another user put in when they first joined).

    Need a Solution to this ASAP this is detrimental to our site!

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.