Skip to:
Content
Pages
Categories
Search
Top
Bottom

Photos Not Showing After Upload WP3.0 + BP 1.2.5.2 + BPA 0.1.7 [PATCH IN PROGRESS]

Viewing 20 replies - 1 through 20 (of 20 total)
  • Avatar of Eduardo Franco
    Eduardo Franco
    Participant

    @egoasterisco

    sorry for my bad english, please try to understand this.

    i have the same problem, this happen in wordpress 3.0 with MULTISITES allowed, and buddypress 1.2.5.2 (and 1.2.5)
    you can look the url of this image error is something like “domain-ABSPATH-url-of-your-img” , if your delete the part of abspath,
    the url is correctly and the image shows.
    then i search in the plugin and i found this.

    EDIT & SOLVED (at last for me): in wordpress 3 multisite the abspath change ‘the format’, so you can modify a little line in:

    in the line 368 of bp-album-screens.php, said:

    $abs_path_to_files = defined( ‘BLOGUPLOADDIR’ ) ? str_replace(‘/files/’,’/’,BLOGUPLOADDIR) : ABSPATH;

    i change the last line for
    // $abs_path_to_files = defined( ‘BLOGUPLOADDIR’ ) ? str_replace(‘/files/’,’/’,BLOGUPLOADDIR) : ABSPATH;
    $abs_path_to_files = ABSPATH;

    it works for me, i dont know the colateral damage.

    what do you think?

    Avatar of Philo Hagen
    Philo Hagen
    Participant

    @philohagen

    BuddyPress Album+ worked beautifully at http://www.mydomain.com/wordpress... but when I moved the site to http://www.mydomain.com for the launch today the images seem to upload, but are no longer showing up. I’ve looked at it from a few angles and would appreciate some insight on the easy fix.

    Avatar of Eduardo Franco
    Eduardo Franco
    Participant

    @egoasterisco

    @philo_hagen the new images/uploads shows correctly?

    Avatar of Philo Hagen
    Philo Hagen
    Participant

    @philohagen

    It appears that they’re uploading correctly, only then they’re missing from the photo album itself.

    Avatar of Eduardo Franco
    Eduardo Franco
    Participant

    @egoasterisco

    look de url of the img, it has the old root?
    i mean
    mydomain.com/wordpress/imageroot.jpg

    or

    mydomain.com/imageroot.jpg ?

    Avatar of kbeatt
    kbeatt
    Participant

    @kbeatt

    @eduardo_franco I tried changing line 368 of bp-album-screens.php, but there was no change. I am using wordpress 3.0 in mutisite mode. Any other ideas?

    Avatar of foxly
    foxly
    Participant

    @foxly

    @philohagen So to clarify then:

    1) Images uploaded before you moved the blog do not work, and,
    2) Images you uploaded *after* you moved the blog *do* work?

    ^F^

    Avatar of Philo Hagen
    Philo Hagen
    Participant

    @philohagen

    @eduardo yes, the photos are still going to and getting the old root label

    mydomain.com/wordpress/imageroot.jpg

    while the album page and code are for the photo is listed at the new root. “mydomain.com/imageroot.jpg”

    @foxly No. When the blog was at mydomain.com/wordpress/ images uploaded and displayed beautifully. Then I launched and moved the index to mydomain.com and album stopped working.

    Avatar of foxly
    foxly
    Participant

    @foxly

    @philohagen

    By moving the blog, you broke all of the image links. Version 0.1.9 automatically handles this situation, but version 0.1.7 (which you’re using) does not. It hard codes the image paths into the database. You’ll either have to run a SQL command that removes the /wordpress/ string from the filepath and URL columns in the database. If you’re not experienced with SQL, just leave it alone until we get 0.1.9 out.

    When version 0.1.9 is released, it will be able to upgrade your “mydomain.com/wordpress” installation to dynamic image links, and then you’ll be able to move it to “mydomain.com” and it will continue functioning.

    ^F^

    Avatar of webgyrl
    webgyrl
    Member

    @webgyrl

    My images also do not show up with
    WP 3.0 w/ Multisites on
    BP Version 1.2.5.2
    BuddyPress Album+ Version 0.1.7

    I can upload the image, but it does not show up.
    /public_html/wp-content/uploads
    /public_html/wp-content/uploads/album
    /public_html/wp-content/uploads/album/1
    All permissions of above are set to 777

    Any idea why they don’t show up. This is a brand new install of WP/BP.

    Thanks!

    Avatar of work
    work
    Member

    @work

    HI there! In path to photo You have this adress: http://natfriends.com/home/wwwnatf/public_html/wp-content/uploads/album/1/fence-natalie-brown-150×150.jpg is include virtual serwer path. I see Your uploaded picture on http://natfriends.com/wp-content/uploads/album/1/fence-natalie-brown-150×150.jpg
    This part of path is inapropriate [/home/wwwnatf/public_html/] You should check blog settings defined path in “Upload Path”

    Avatar of webgyrl
    webgyrl
    Member

    @webgyrl

    @work

    Thanks for the reply. I can not seem to find where to change these settings.

    I have gone to:
    Super Admin > Options: http://i29.tinypic.com/5umhas.jpg

    BP Admin > BP Album settings: http://i25.tinypic.com/30rw4gj.jpg

    Settings > Media: http://i26.tinypic.com/2yvo0o3.jpg

    Where do I change the “upload path” to fix this?

    Thanks so much!

    Avatar of work
    work
    Member

    @work

    Should work: [SUPER ADMIN] -> [SITES] and then on Your main site go to [edit] option and find “Upload Path”,try to delete this part of path “home/wwwnatf/public_html/” :D

    Avatar of Ronia
    ronia
    Participant

    @ronia

    Same problem.
    New installs of WP3 as sub-dir MS and BP 1.2.5.2. And BP-album 0.17. All fresh.

    Photo get uploaded but not displayed.

    Avatar of Ronia
    ronia
    Participant

    @ronia

    @egoasterisco hello! Thanks a lot. Your solution seems to be working :)

    Avatar of webgyrl
    webgyrl
    Member

    @webgyrl

    @work
    My upload path says:wp-content/uploads

    See: http://i30.tinypic.com/k0j8f6.jpg

    I’m assuming there is a patch in progress and that this is a known issue based on the revised forum title?

    Thanks so much for the help!

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    Yes we are working on a maintenance release to patch compatibilty issues that raised with latest versions of wp and bp in some envoirments with the 0.1.7 stable tag.
    Although you all have same problem it seem that there can be different causes.
    I’ve not been able to reproduce this problem on any test install, this means I’ll probably ask you to test some possible solutions or more information when needed. I’ll write here any update on this problem.

    @ronia & @egoasterisco : that solution looks more likely to fix an incorrect .htaccess , could you please paste the content of your .htaccess file in a http://pastie.org/ and write the url here? that would help to understand if problem was on your .htaccess or if something changed in wp3 url rewriting making old style url to files unusable.

    @work that’s interesting, I mean that wordpress was unable to detect the right relative path to uploads folder. What kind of hosting (shared,local,vps,…) is your site running on?

    Thanks
    Francesco

    Avatar of Philo Hagen
    Philo Hagen
    Participant

    @philohagen

    @foxly

    >>You’ll either have to run a SQL command that removes the /wordpress/ string from the filepath and URL columns in the database.<<

    Thank you. Question: What is the sql command to run? How do I take the /wordpress/ string from the filepath and URL columns in the database, to make my users photo’s load to the right place?

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @philohagen you skipped the part “If you’re not experienced with SQL, just leave it alone until we get 0.1.9 out.” ? ;)

    ***Make database backup and be sure you can restore it before doing any other operation***
    try to give a look to this page http://codex.wordpress.org/Changing_The_Site_URL, there should be a part on changing urls in post table, it should be valid also for changing urls in bp-album table changing table name. If it doesn’t help google is your friend :)

    Avatar of bymiki
    bymiki
    Participant

    @bymiki

    Hi guys. I have the same problem, for any reason the plugin try to charge the images from an incorrect url: http://www.mydomain.com/usr/home/mydomain.com/public_html/wp-content/uploads/album/

    I dont know why, maybe because i have wordpress install in a subdomain??? anyway I get a temporally solution until the version 0.1.9 is finished. I just make a 301 redirect from .htaccess like this:

    Redirect 301 usr/home/mydomain.com/public_html/wp-content/uploads/album/ http://mydomain.com/wp-content/uploads/album/

    Now works fine, the images charges correctly.

    I hope this can help you.

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.