Skip to:
Content
Pages
Categories
Search
Top
Bottom

plugin errors

  • HI -

    I seem to encounter this issue quite frequently with plugin installation.

    I am using Buddypress 1.0.1

    With WordPress MU 2.7.1

    Theme: Facebuddy 1.0

    Error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/xxxx/public_html/XXXXXX/wp-includes/kses.php(408) : runtime-created function on line 1

    Result: plugin admin page view is completely removed and replaced with the fatal error message. Sometimes if I go to the Dashboard page, the left column (of the right section) is completely displaced and gone as well.

    Fix: delete the plugins from the control panel.

    Had this issue with Nicola’s Extra group plugin

    Had this issue with Nicola’s Widgets plugin

    Had this issue with bpcontents10a21

    Currently installed and working fine widgets:

    bpdevcore

    bpdev flickr

    bpdev tinymce

    remove buddypress admin bar

    TwitterToWire

    Anyone else encounter this? Got any ideas?

    Thanks,

    Brian

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    It looks like PHP is running into a memory limit. So, you need to help PHP by boosting its memory limit.

    Make a file called php.ini. Inside this new file, put this:

    memory=48MB

    There is more that can be added to that if you’re still having issues. But for now, let’s make it as simple as possible.

    Once you’ve created that file, upload it to your wp-admin directory.

    On some installs, I’ve had to boost the memory to 96MB. If 48MB does not work, try increasing.

    Let me know how that goes.

    Hi Jeff,

    Thanks for the advice. Unfortunately, no luck. I created the file you recommended in my control panel, and simply put the code you wrote in the first line without anything before or after. I say that because I am still relatively new.

    Then I uploaded Burt’s bpcontent plugin and logged in to the admin of buddypress, and found this, in the development log section of the Dashboard:

    “Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/xxxxx/public_html/XXXXXX/wp-includes/rss.php on line 712″

    So then I deleted the two files that followed Burt’s installation instruction, and changed the ini file to 96 from 48.

    I then uploaded the plugin again, and logged in again and found the same error. Boost it even more, to 144?

    Thanks,

    Brian

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Brian-

    Okay, try changing your new, custom php.ini file to this:

    memory_limit=48MB
    upload_max_filesize=10M
    post_max_size=20M

    Also, is your site running PHP4 or PHP5?

    Hi Jeffy,

    Thanks for your welcome message and your advice. I have already succeeded with the header changes.

    Unfortunately, this memory issues is still causing a problem. I am running PHP5 – 5.2.9

    Here is the latest error message:

    “Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/xxxx/public_html/XXXXX/wp-admin/menu-header.php on line 89″

    It’s basically the same thing, although it sometimes highlights a different file. I see other folks have experienced the same issue. Could this be a hosting issue? Do I need to call them and ask for a larger memory or something?

    Thanks so much for your time.

    Brian

    Hi Jeff,

    I just got off the phone with Host Monster technical support. After explaining the problem, they took a look at my files and indicated that my php installation, 5.2.9, is configured to look for a php.ini file in only one location, the public_html file, and there was no php.ini file there. So the php.ini file I had sitting in the wp-admin folder just sat there, unexamined.

    Host Monster installed a php.ini file for me and I made the changes you suggested. I then refreshed my Buddypress admin page and lo and behold, there was the bpcontents plugin ready to be activated, and no error message.

    Thanks so much for your time and I am sorry I bothered you with this but I hope this post will help others who may encounter a similar issue.

    Cheers,

    Brian

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Lots of people run into this issue, not only with BuddyPress but almost any php web package. Web hosts just don’t want to allocate that much memory to their users unless they need it.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Brian-

    I’m glad it all worked out! Those darn php.ini files can mess you up sometimes. :)

    Avatar of rogiertje
    rogiertje
    Member

    @rogiertje

    I’m having the same problem.

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 4864 bytes) in /storage/mijndomein/users/095442/public/sites/www.naarijsland.nl/wp-content/plugins/buddypress/bp-groups.php on line 560

    Made a php.ini file and placed it in wp-admin.. in the php.ini all the things Jeff sad..

    :-(( are there any other options?

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Talk to your host and ask them where your php.ini file is/should be.

    The easiest way to configure the php_value memory_limit is to create an .htaccess file in your root folder of your wordpress installation and pass the string into a new line:

    php_value memory_limit 50MB;

    This works fine for me! =)

    Avatar of nagoonline
    nagoonline
    Member

    @nagoonline

    HELP! I installed the BuddyPress plugin and got this fatal error. So, I removed the files from my server using Filezilla and now I cannot access my admin panel. I am really disappointed and upset there was not a warning this would happen.

    Any suggestions would be greatly appreciated.

    @nagoonline: you have asked this in another post, and we have answered. Do not double-post.

    EDIT: Also, sending me a private message is not going to get you a reply any quicker. You could have searched Google to resolve this issue, as it’s a common WordPress “plugins broken my site” question.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.