Skip to:
Content
Pages
Categories
Search
Top
Bottom

Post showing in Activity Stream

  • Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    Hi Guys,

    I have two sites, a primary and a sub site. When a post is made in the primary site is shows up in the Activity Stream (desired), however when a post is made on the secondary site it does not show up in the Activity Stream of that site (not desired). I looked at all of the setting pages but can’t seem to find out why.

    Any help would be greatly appreciated.

    TYIA, Eric

    1. Which version of WordPress are you running?
    3.3.2
    2. Did you install WordPress as a directory or subdomain install?
    Domain
    3. If a directory install, is it in root or in a subdirectory?
    root
    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    Clean install
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    NA
    6. Which version of BP are you running?
    1.5.5
    7. Did you upgraded from a previous version of BP? If so, from which version?
    Nope
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Yes, BuddyPress Multi Network (@sbrahesh), and a few others.
    9. Are you using the standard BuddyPress themes or customized themes?
    WPMU DEV BuddyPress Social Theme
    10. Have you modified the core files in any way?
    No
    11. Do you have any custom functions in bp-custom.php?
    No, other than the Theme
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    No
    13. Please provide a list of any errors in your server’s log files.
    NA
    14. Which company provides your hosting?
    Private on AWS EC2
    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Windows Bitnami stack

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == 8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Yes, BuddyPress Multi Network, and a few others.==

    Are you referring to the BuddyPress MultiNetwork plugin by Ron Rennick (aka wpmuguru) and not the BP MultiNetwork by Brajesh Singh (aka sbrajesh)? Either way, both plugins make each subsite (with own BP instance each) function separately from each other. In other words, using either plugin above, you’re not likely to see the blog posts from the subsite showing up in the main site’s activity stream at all precisely because of the separate instances. Having said that, you should contact the plugin author re best way to go about it.

    Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    @mercime wrote: …you’re not likely to see the blog posts from the subsite showing up in the main site’s activity stream at all precisely because of the separate instances

    I note: Yes, I understand this and this is what I want and expect. By the way I am running sbrajesh’s. I also run BuddyPress Activity Plus and have turned it off and on on both sites. It does not affect the output.

    What I am looking at is notification of new Posts showing up in the Activity Stream of each site. In the main site when I write a Post is shows up in that sites Activity Stream (again this is desired). On the sub site when I write a post it does not show up in that site’s Activity Stream (again not desired, I want it to show up). I would post a screen shot but I don’t know how in this forum…

    I am looking to find out why it shows up in the primary site but not the secondary.

    Thanks,

    ~eric

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == On the sub site when I write a post it does not show up in that site’s Activity Stream (again not desired, I want it to show up). ==

    It’s clear now, thanks. Have you contacted @sbrajesh and informed him about the posts in subsite not showing up in that subsite’s activity stream? He should know about this as I agree with you about the functionality you want.

    Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    @mercime, thanks. I will contact @sbrajesh. How do I do that in BuddyPress.org? I followed him but I don’t see how to send a message…

    ~eric

    Direct messaging is disabled on BuddyPress.org (people kept spamming people). Since you mentioned @sbrajesh, he should have received an email notification. However I suggest you visit his site for support http://buddydev.com/

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    Hi @elangley,
    sorry I could not reply earlier(was a little bit busy with some personal stuff).

    Just checked today the case by writing posts on sub network and It showed up correctly on my local install. I am using Sub directory install though(It should not affect the sub domain install I believe). Can you confirm if you already have BP_ENABLE_MULTIBLOG defined in your bp-custom.php or wp-config.php ?

    @djpaul, @mercime, Thank you for the mention. My apologies for not responding to this topic earlier. I had got the notification.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @sbrajesh No worries. Thanks for your response. :-)

    Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    @sbrahesh, yes, I have BP_ENABLE_MULTIBLOG enabled in wp-config.php

    ‘define( ‘BP_ENABLE_MULTIBLOG’, true );’

    @elangley

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.