Skip to:
Content
Pages
Categories
Search
Top
Bottom

Private blog posting in public activity stream

  • Avatar of fcastro72
    fcastro72
    Participant

    @fcastro72

    Hello, is there a way to hide private blogs to appear in the public stream.
    Right now when a user posts a new article in a private blog, everyone can see the update in the activity stream.
    Thanks
    Fabio

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    Is the blog definitely set to private as thought (haven’t checked) if it was it wasn’t designed to show in stream? Someone else may be able to confirm that but thought it was the case.

    Avatar of WPwebbouw
    WPwebbouw
    Participant

    @wpwebbouw

    How do you set a blog as ‘private’ in a multisite / Buddypress setup?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    You do that in Settings > Privacy where you choose “Ask search engines not to index this site.”

    Avatar of fcastro72
    fcastro72
    Participant

    @fcastro72

    Hi Karmatosed, are u saying that if i check the blog as No Google it will not show in the public stream?
    I’m going to check
    Thanks

    Avatar of fcastro72
    fcastro72
    Participant

    @fcastro72

    It doesnt work even if the blog is no googlable or set to blog members only i have the activty stream for every user, of course when i click on the link it says the user has not the permssission to read that page.

    Avatar of fcastro72
    fcastro72
    Participant

    @fcastro72

    Ok i found the problem, i have the more privacy option plugin installed, so if i set the value to blog only member i have the blog post showing in the activity stream.
    So i think it would be fine for me to modify the code in order to change where is defined to set hide_sitewide = 1 for private blogs (extending to member only blogs)
    Anyone knows where in the code this is checked?
    Thank you

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.