Skip to:
Content
Pages
Categories
Search
Top
Bottom

Private Messaging & multiple recipients -> Discussion -> unintended Spam

  • Avatar of thomasbp
    thomasbp
    Participant

    @thomasbp

    Hi!

    My users are complaining about private messaging spam, which is actually – as far as I can see – a feature.

    When I send a message to let’s say 10 friends (who are not necesserily each others friends) and one of them answers, all the others get his answer. Even though they are not each others friends.

    That happens, because a discussion is automatically opened between all recipients. Some users had suddenly 40 messages or more.

    Is there a way to disable these auto discussions and to send the reply as default only to the sender? “Answer to sender” should be the default, and “answer all” an optiona feature. Like in all email clients.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    My guess is you are not quite understanding the way private messaging was intended to work. As the name implies, it is a private message. When you send a “private” message to 40 friends, it’s not quite “private” anymore, by some definitions. The same occurs in email when one of your 40 recipients hits “reply all” assuming they were not bcc’d.

    As such, when you send a bp message to 40 people, you are, in a sense, establishing a 40 person thread. That’s the way it’s supposed to work (which is great for smaller numbers) In other words, expect 40 replies to the thread and all 40 will get 40 messages. Seems ripe for trouble when you send it to 40! (btw, I am impressed you were able to have the patience to pull off 40 as you had to remember and type 40 names or usernames since this is the only way to do it in BP at the moment.

    Second, if you send a message that, upon reply, many members will deem the response as “spam” consider not starting the thread. Just remember, BP messaging was not meant to be like email.

    Avatar of thomasbp
    thomasbp
    Participant

    @thomasbp

    Thx, I got it, but my users won’t, since they see a PM rather as an email and not as another kind of a discussion group (core age 15, so they have plenty of time to enter all the names :) ). It’s also in my opinion not intuitive.

    If there is no simple way to include a “no bcc” option – is there a way to limit the number of recipients to one user?

    Avatar of jivany
    jivany
    Participant

    @jivany

    Raise a ticket. This is a usability/privacy issue. It should be blatantly obvious to the user who is replying to a private message that they are sending to more than the sender.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.