Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem intalling Forums in Buddypress: Fatal error: Out of memory (allocated 31719424) (tried to al

  • Avatar of faceteletv
    faceteletv
    Member

    @faceteletv

    Hi, i install buddypress, and when i install the buddypress forums and it show me this error>

    Fatal error: Out of memory (allocated 31719424) (tried to allocate 19456 bytes) in /homepages/39/d356648964/htdocs/wp-admin/includes/misc.php on line 501

    Any help plss. my site: http://www.Facetele.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    @faceteletv

    You’ll need to increase the filesize upload limits. See this post for some helpful tips:

    http://buddypress.org/community/groups/installing-buddypress/forum/topic/installing-buddypress-1-2-6-to-wordpress-3-0-1/

    Avatar of aces
    aces
    Participant

    @aces

    @faceteletv

    You look like you are using 1and1 shared hosting which has very low memory allowances for running buddypress….. see http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/rss-error-in-dashboard#post-88690 if you are.

    1and1 have also disabled any tricks I have found that were supposed to increase memory….

    They say on their uk website that even if wordpress reports more than 30mb it won’t be accurate – and my experience shows it should be less than that!

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    You can also try the instructions listed here to increase your memory limit:

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Avatar of aces
    aces
    Participant

    @aces

    @r-a-y – If this is a 1and1 shared hosting memory issue then that will not help. WordPresss may report a higher memory but 1and1 servers will still be stuck at 30mb….. I would love to get round this problem myself, other than by limiting what plugins and themes etc I can run….

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Okay, if you’re running a lot of plugins, consider disabling a ton of them and only enable BuddyPress and then see if your memory problems go away.

    Another thread on the situation:
    http://buddypress.org/community/groups/installing-buddypress/forum/topic/how-much-php-memory-should-be-allocated-to-buddypress/

    But, it might be better to start looking for a better host.

    Avatar of aces
    aces
    Participant

    @aces

    @ray

    I think you are right about needing a better host, but it isn’t that simple…

    All the hosts I recently had a look at don’t publish their memory constraints in their advertising.

    One I know of said on the phone that their memory was effectively unlimited (and it seemed so for what I was trying to do), or so I was told by their custormer…. but I think that they were down for about 29 hours in a row recently…

    Avatar of aces
    aces
    Participant

    @aces

    @faceteletv

    I’m trying to keep this conversation within topic here where you originally mentioned it, rather than wild in the activity stream.

    I’ve managed to get forums working on a 1and1 shared hosting…

    I don’t think any of the wp-config.php or .htaccess or php.ini tricks for increasing memory work for 1and1 shared hosting. Even if wordpress tells you it has more, it will still behave as if it hasn’t…

    As ray said, you should disable as many plugins as possible at least till the forums are enabled. I already mentioned what I had done about plugins here

    To find out how much memory a plugin or theme is using I use http://wordpress.org/extend/plugins/wp-system-health/.

    You appear to be using buddypress social theme – which I haven’t tried but it has lots of options and may use lots of memory. With limited memory it would be better to use a simple child theme of buddypress default and customise it.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Said this before, but worth saying again, this setting does NOT technically increase the memory It adjusts the ‘Limit’ of memory available, it’s a safeguard feature that prevents scripts from consuming too much memory, increasing it blindly is NOT a good thing to do as the point of the exercise is to do what is being seen here, that of killing the script trying to run and bring down the system. If you – in theory – increased the limit to the max the box provided you could then run a script which infinitely looped, and that in turn would crash the box and all sites running on it requiring a re-boot to get the system back up. I would expect any good hosting service to preempt users trying to change this setting.

    Following Ray’s advise to disable plugins should be attempted in the first instance.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.