Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem uploading an avatar

  • Avatar of Coto
    Coto
    Participant

    @coto

    I have the next error uploading an avatar

    Warning: getimagesize(Object) [function.getimagesize]: failed to open stream: No such file or directory in /var/www/html/SITE/wp-content/plugins/buddypress/bp-core/bp-core-cssjs.php on line 93

    I can upload files in Post, but not an avatar.

    These are my configuration:

    PHP 5.1.6 (cli) (built: Feb 26 2009 07:01:10)

    Apache/2.2.3 (built: Jul 15 2009 09:02:36)

    mySQL 5.0.7

    WordPress MU 2.8.4a

    BuddyPress 1.1.1

    chown USER:apache -R /var/www/html/SITE/

    chmod 755 -R /var/www/html/SITE/

    chmod 777 -R /var/www/html/SITE/wp-content/blogs.dir/

    chmod 666 /var/www/html/SITE/.htaccess

    chmod 666 /var/www/html/SITE/wp-settings.php

    chmod 666 /var/www/html/SITE/wpmu-settings.php

    chmod 666 /var/www/html/SITE/wp-config.php

    chmod 666 /var/www/html/SITE/wp-content/wp-cache-config.php

    Thanks a bunch!

Viewing 7 replies - 1 through 7 (of 7 total)
  • I assume your web server is actually part of the ‘apache’ usergroup? ;)

    Avatar of Dizziness
    dizziness
    Participant

    @dizziness

    Same problem here. Avatar generated but corrupt/incomplete.

    Need to see http://buddypress.org/forums/topic/when-asking-for-support from both of you to confirm that you both have the same issue. You might be having the same problem but with different causes.

    Avatar of Coto
    Coto
    Participant

    @coto

    1. Which version of WPMU are you running?

    A. 2.8.4a

    2. Did you install WPMU as a directory or subdomain install?

    A. subdomain

    3. If a directory install, is it in root or in a subdirectory?

    A. -

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    A. Yes, WPMU 2.8.1

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    A. No

    6. Which version of BuddyPress (BP) are you running?

    A. 1.1.1

    7. Did you upgraded from a previous version of BP? If so, from which version?

    A. BuddyPress 1.0.2

    8. Do you have any plugins other than BuddyPress installed and activated?

    A. MobilePress 1.0.4, WP Super Cache 0.9.7, RSS Cloud 0.3.2 and Members Only 0.6.7 (The problem persists if i disable all plugins)

    9. Are you using the standard BuddyPress themes or customized themes?

    A. Standard themes

    10. Have you modified the core files in any way?

    A. no

    11. Do you have any custom functions in bp-custom.php?

    A. no

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    A. bbPress built-in

    13. Please provide a list of any errors in your server’s log files.

    A. [Mon Oct 19 15:04:41 2009] [error] [client 192.168.1.226] PHP Warning: getimagesize(Object) [function.getimagesize]: failed to open stream: No such file or directory in /var/www/html/blogsmu/wp-content/plugins/buddypress/bp-core/bp-core-cssjs.php on line 93, referer: http://blogs.epson.cl/members/coto/profile/change-avatar/

    Avatar of Coto
    Coto
    Participant

    @coto

    @DJPaul can you telll me. how i can ensure if the web server is actually part of the ‘apache’ usergroup

    thanks a bunch

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?
    A. No

    What wasn’t working properly? You can’t expect BuddyPress to work if WPMU wasn’t working properly first.

    I think this error relates to not being able to manipulate files in /var/www/html/SITE/wp-content/blogs.dir/. Hmm.

    With regards to what group/user your web server runs at, if this isn’t your own server, your host can help. Where are you getting hosting?

    Avatar of Coto
    Coto
    Participant

    @coto

    Sorry, was a mistake. I meant to said yes, because always i could upload files with WPMU, but not avatars with BuddyPress

    <b>5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    A. Yes<b>

    I think isn’t related with permissions because… look at its permission:

    chmod 777 -R /var/www/html/SITE/wp-content/blogs.dir/

    I did it myself

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.