Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem w/ creating groups. Avatar step and Group Blogs does not work, can’t complete.

Viewing 9 replies - 1 through 9 (of 9 total)
  • BTW, here are my site specifications.

    Specs

    1. Which version of WPMU are you running?
    I am using regular WP 3.0
    2. Did you install WPMU as a directory or subdomain install?
    Root directory
    3. If a directory install, is it in root or in a subdirectory?
    Root
    4. Did you upgraded from a previous version of WPMU? If so, from which version?
    Was a previous version install via Fantastico on cPanel, upgraded to 3.0 before BuddyPress was installed
    5. Was WPMU functioning properly before installing/upgrading BuddyPress?
    Not sure
    6. Which version of BuddyPress (BP) are you running?
    Version 1.2.5.2
    7. Did you upgraded from a previous version of BP? If so, from which version?
    No
    8. Do you have any plugins other than BuddyPress installed and activated?
    Yes:
    Welcome Pack Version 2.1
    Twitter Goodies Version 3.9.0
    Tweetstream Version 1.4
    oEmbed for BuddyPress Version 0.52
    Invite Anyone Version 0.6.4
    Import from Ning Version 1.1
    Facestream Version 1.1
    Contact Form 7 Version 2.2.1
    BuddyPress Usernames Only Version 0.58
    BuddyPress Profile Privacy Version 0.2
    BuddyPress Private Messages for Followers Only Version 1.0
    BuddyPress Like Version 0.0.7
    BuddyPress Group Tags Version 1.2.2
    BuddyPress Group Email Subscription Version 2.5
    BuddyPress Forum Topic Mover Version 1.0.0
    BuddyPress Follow Version 1.0
    BuddyPress Album+ Version 0.1.7
    BP Profile Search Version 1.0
    BP Group Management Version 0.4
    BP-NotificationWidget Version 1.4
    9. Are you using the standard BuddyPress themes or customized themes?
    Standard BP Theme BuddyPress Default 1.2.5.2
    10. Have you modified the core files in any way?
    No
    11. Do you have any custom functions in bp-custom.php?
    I do not think so.
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    I ran the bbPress installer that came with BuddyPress
    13. Please provide a list of any errors in your server’s log files.
    DELETED logs….
    I moved files in site to root…..
    Hosting company:
    Total Choice Hosting

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I should think the second line in that error log is the problem. open_basedir restriction is something – I believe – that web hosts will employ to ensure safety protocols between different sites on same shared server, it essentially states a directory within which scripts are permitted to run, and in this instance is possibly proving too restrictive.

    You will probably need to open a ticket with your web host and ask them what restrictions are in place, mention the above and ‘PHP Safe Mode’ and ask them if anything can be done to rectify the issue their end, also it may simply be a group permissions issue where you do not have apache as owner of the directory and therefore are trying to perform actions as a group that is being denied.

    Not sure if this will help but it’s sounding more like server issues than BP/WP and if you are on shared hosting it will be best to see what your web hosts can resolve for you.

    hnla; Thanks so much! So should I ask my host how to turn open_basedir on? I can do stuff via .htaccess.. for example I have Register Globals off via .htaccess on another site I have on that host.

    Basically, what command am I looking to enable?

    Thanks!

    I just emailed them. I did a complete re-install of WP so I could get a fresh start to enable the newtowrk. I got the same open_basedir restriction when trying to upload avatars, but this time I at least got more useable error info to email the host with. This is what it said this time:
    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/wwwnatf:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/wwwnatf/public_html/wp-includes/functions.php on line 2037

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/wwwnatf:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/wwwnatf/public_html/wp-includes/functions.php on line 2028

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/wwwnatf:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/wwwnatf/public_html/wp-includes/functions.php on line 2037

    Upload Failed! Error was: Unable to create directory /group-avatars/1. Is its parent directory writable by the server?

    I wonder if it’s just a CHMOD issue or a CHOWN one?

    EDIT
    Ok Tech mailed me back with this:
    I have disabled open base restriction for, natfriends.com. Please check it now and let us know if you need any further assistance.

    But I still can’t upload. When I do I get this error message:
    Upload Failed! Error was: Unable to create directory /group-avatars/1. Is its parent directory writable by the server?

    Where is this directory “/group-avatars/1″ what folder does it live in? Maybe permissions need to be 755?

    Thanks!

    OK they fixed it. They had to disable php safe mode to get it working.

    Thanks for the tips and help :)

    Oppps… spoke too soon. Now it’s broken again.

    So basically php safe mode is off and open base restriction is disabled.

    I activated the plugin BP GroupBlogs Version: 1.4.4: http://buddypress.org/community/groups/bp-groupblog/

    When I did this, I noticed that when I went through the process to create a group, that part came up blank and then I would be sent to the WP failure notice that says:
    Are you sure you want to do this?

    Please try again.

    After that I could not move past to the Avatar upload step.

    So I disabled the plugin, but then it would do the WP error at the Avatar step and now it’s not working again.

    Here is a video of exactly what I did:
    http://img101.imageshack.us/img101/3226/grpblogavatarissue.mp4

    My host said that if there is any info anyone here at BP can give them, they can look into it, but I’m just not sure what the issue is.

    Thanks!

    Alright back again… this is what I have done.

    Deactivated every plugin
    Cleared cache and cookies
    Closed browser
    Came back and logged in
    Created group
    Everything worked fine
    Started to re-activate plugins one by one
    Started first with BP Groupblog
    It actually WORKED
    Until I went to the last phase which was invites (I have no members) so I just clikced next.
    Got this error:

    Warning: Invalid argument supplied for foreach() in /home/xxxxx/public_html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php on line 23

    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxx/public_html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php:23) in /home/xxxxx/public_html/wp-includes/pluggable.php on line 890

    http://i28.tinypic.com/vpkivs.jpg

    Any ideas what is causing this Invalid argument?

    I’m going to disable it again. But I would really like to get Group Blogs working if possible.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    You will probably need to check that plugin doesn’t have any known issues reported (there should be a group plugin page for it?)
    See you have found and joined that group. I’m afraid I don’t know the current state of play with that plugin, but it may well need updating by the author before it’s fully compatible with all current WP/BP?

    From an earlier comment : this line worries me:
    for example I have Register Globals off via .htaccess on another site I have on that host.
    Register Globals should never be on really – it was and is a very insecure and dangerous thing and PHP changed it’s default status in php.ini years ago. I hope your host doesn’t have that set ‘On’ as default for all their client sites

    OK they fixed it. They had to disable php safe mode to get it working

    Yep safe mode was the issue (essentially it’s what controls open_base )

    File and directory permissions do need to be set correctly and safely. Generally directories need to be 755 and files 644, and I think if you need to be able to edit theme files from the backend/dashboard then those theme files need to be 666. Always avoid 777 as that is world writable and dangerous.
    http://codex.wordpress.org/Changing_File_Permissions

    However permissions are only one half of the story, you can have them all set correctly and still not be able to create directories such as /group-avatars/. What is essential is that ownership permissions are correct and for these directories to be writable or for files to be able to be moved to their correct location you must have the correct groups set such as ‘apache’ for the parent wp-content directory.

    Avatar of Josh McKenney
    Josh McKenney
    Participant

    @jmckenney

    I narrowed down my issue to buddypress welcome pack plugin:( too bad, really liked that plugin…

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.