Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem with editing course, missing tab – version 0.9

  • WordPress 3.2.1, BuddyPress 1.5 RC1, Courseware 0.9

    I’m having some trouble editing a course where Courseware is enabled on a specific group. When I click the “Edit Course” button, I get a “Page not found” error.

    Also, the Courseware tab does not show up on the group tab set.

    I have poured over all of the possible configurations and can’t seem to get past these two issues. What could be the problem?

    Thanks.

Viewing 22 replies - 1 through 22 (of 22 total)
  • Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    I have a sandbox with latest BuddyPress and everything works.
    Are you sure you are on BuddyPress trunk (latest svn revision)?

    Avatar of Quint
    Quint
    Participant

    @qrahaman

    @markcorgan and @sushkov

    WordPress 3.2.1, BuddyPress 1.5 RC1, Courseware 0.1.6 (downloaded from WordPress plugin directory)

    I have verified Mark’s observations. I have also followed the handbook (http://scholarpress.github.com/buddypress-courseware/handbook.html) up to the Dashboard section. No Courseware tab shows up on the group page (as shown in the diagram). Under Groups>Admin, the Courseware setting’s tab shows (which allows the admin to enable Courseware Status and Private Responses).

    For newly created groups, the following is shown right after the group has been created:

    You can manage this group Courseware. Update course information »

    I selected “Update course information” which results in “New course was added”. There is no Courseware tab as depicted in the diagram; however, the secondary menu shows up; that is, “Home”, “Course Description”, New Assignment”, etc. By default “Course Description” is highlighted but nothing is shown in that tab. When I click on “Course Description”, then a few items populate the tab: the name of the group, a text box which contains my group description info (cannot change it when selected), and over to the right is, Course Info, the date, and the Bibliography and Edit Course buttons.

    I selected the Edit Course button and doing so, takes me right back to the where I was after I had selected “Update course information” minus the “New course was added” message.

    By the way Stas, I watched your tutorial. Very slick! :-) One question for you regarding the quiz capability. Can a teacher request a video/media submission as a response to a quiz question? For example, as a part of the quiz, a woodworking instructor asks the student to upload a video of the process of the student creating a matching mortise and tenon joint. Could that be done with your plugin? And could a quiz question display a video with attached questions?

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    First of all:
    `
    WordPress 3.2.1, BuddyPress 1.5 RC1, Courseware 0.1.6 (downloaded from WordPress plugin directory)
    `
    WONT WORK!!! Stop this madness and please read the forum announcements!!!
    The only version of Courseware that works with BP 1.5 is 0.9 and it is available only from github/plugin-repo!

    What about the responses to quizzes, yes, that is possible.
    It was possible since 1.6.

    Avatar of Quint
    Quint
    Participant

    @qrahaman

    @sushkov, okaaaayyyyy. I am very new to WordPress, Buddypress, and certainly to the workflow and where content on this site, et al resides. And I try to contribute as best I can to those questions for which I am comfortable answering. What you’re calling “madness” are my attempts at learning all of it and trying to help the poster and/or the author. And I do try to be as meticulous as I can when doing the testing and providing feedback in a way and with context such that noobies like myself can follow and understand. I certainly don’t want to waste anyone’s time.

    When you say, “forum announcements”, I really don’t know to where you are referring. If it’s this particular question where you answered “Are you sure you are on BuddyPress trunk (latest svn revision)?”, then that is my fault. The terms “trunk” and “svn” are jargon for this community/discipline. I am trying to learn the jargon and in this case, they didn’t click with me. I will go to github, wherever that is, download 0.9 and try it.

    P.S. I am still young enough that I can still hear very well. ;-)

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    Hey, @qrahaman
    sorry if it sound too rude from my side.
    The problem is that I received a bunch of emails and forum questions about 1.5/0.9 compatibility, and people simply don’t want to help themselves. That’s what I meant by saying `madness`.

    I can only say, there’s probably a week or so and BP 1.5 might be released, so please get some patience :)
    I’m waiting for this release since early august…

    My apologies please.

    Avatar of Quint
    Quint
    Participant

    @qrahaman

    @sushkov, no problemo. I understand completely. By the way, 0.9 is working on my local installation. Impressive work! :-)

    After a fresh WP 3.2.1 install, a fresh BP 1.5 RC1 install and a fresh CW 0.9 install, as well as a brand new MySQL database, I’m still having the problem of “Page not found” when clicking the “Edit course” button. The Courseware tab does not show up for the group either and it has been enabled for the group.

    Any thoughts?

    BTW, this is the zip file I downloaded is:

    scholarpress-buddypress-courseware-0.1.6-95-g1b93011.zip

    Is this the correct one? If not, where do I download the latest build on github?

    Avatar of imjscn
    imjscn
    Participant

    @imjscn

    the file name is 0.16 , after you uploaded, WP recongnize it as 0.9, that’s a bit confusing.

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    @imjscn i didn’t upload anything, it’s how it’s generated.

    @markcorgan I’m sorry, you are doing something wrong.

    http://dl.dropbox.com/u/20301790/trash/cw.mpg

    @imjscn Yes, the version is set to 0.9 in the plugin file. Thanks for the info.

    @sushkov When I click your link, I get a Quicktime video of a build process. It runs for a while and then nothing else happens. Is the link supposed to be for an archive on Dropbox? Thanks.

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    @markcorgan it’s a screencast showing how I test latest versions. Just right-click and save link as… than try to play it.

    @sushkov Oh, OK. Thanks. Any suggestions as to where I should start looking? What code processes the “Edit Course” button action? What should the URI be? Also, where is the code that decides on whether to show the Courseware tab or not? Thanks.

    Just an FYI, the new release (0.9) I downloaded from this group works fine. Must have been some mix up in the downloadable archives (most likely on my part!).

    Great job on the plugin! It’s looking good.

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    Good to know you sorted it out ;)
    Thanks.

    Avatar of vipulpratap
    vipulpratap
    Participant

    @vipulpratap

    I’m facing this issue that when i click – edit course on

    You can manage this group Courseware. Edit Course

    The next page it shows is –

    Page not found

    We’re sorry, but we can’t find the page that you’re looking for. Perhaps searching will help.

    i’m using buddypress 1.7.1 and courseware 0.9.7

    please help. Snapshot attached

    https://docs.google.com/file/d/0B3UQkqR2mCTOZGlRcnFzTEtWaHc/edit?usp=sharing

    https://docs.google.com/file/d/0B3UQkqR2mCTOdG52OGVvX2VRSnM/edit?usp=sharing

    Avatar of christian.j.king
    christian.j.king
    Participant

    @christianjking

    I’m having the exact same issue after updating Buddypress. I’ve done a lot of looking around for a fix but I’ve come up with nothing. I love courseware and I hope it’s just a matter of time until it’s current. Thank you all for all your great work!

    Avatar of henriqueznx
    henriqueznx
    Participant

    @henriqueznx

    I have the same problem of the user vipulpratap.

    I tried change the permanlinks but dont fix it.

    Avatar of suri1978
    suri1978
    Participant

    @suri1978

    Its been almost two years since this “404 issue on edit course button” reported ion this thread. But it seems the issue is still there. I am not WP expert. I just installed BP Courseware from the plugin directory following the normal steps as I do with other plug ins. And I too get the 404 error on “edit course” button. Have been trying many fixes and spending lot of time reading on how to fix this. But nothing has worked yet. Can someone pls help

    Avatar of gonrojas
    gonrojas
    Participant

    @gonrojas

    i have the same problem… Edit course button ==> page no found, and never have the courseware tab in menu

    Avatar of coded007
    coded007
    Participant

    @coded007

    i am using wordpress 3.6, BuddyPress 1.8.1 and BuddyPress Courseware 0.97 but the courseware is not working properly.

    i created a group and when i clicked on the Edit Course button it says “Page not found
    We’re sorry, but we can’t find the page that you’re looking for. Perhaps searching will help.”

    please i need help?

    Avatar of imckinney
    imckinney
    Participant

    @imckinney

    Just a guess here but I think this has been abandoned by the creators. It looks like they are about to release a paid software that does the same thing. There have also been no updates in a year so…. Anyone know a good alternative?

Viewing 22 replies - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.