Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem with subdomain

  • I use hosting with limit for subdomains. Subdomains is creating from hosting control panel, and when I create new blog from BP, subdomains don’t work. Is there any solution or I have to change hosting provider?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Use the subdirectory option when installing WPMU.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Or, enable wildcard DNS support if your host allows that.

    Avatar of Dainismichel
    dainismichel
    Participant

    @dainismichel

    since subdomains are recommended, is there a way to switch to subdirectories afterwards, thereby creating.

    community.domainname.org/userblog/

    instead of

    userblog.community.domainname.org

    Best,

    Dainis

    Avatar of Felix2009
    Felix2009
    Participant

    @felix2009

    In youre wordpress mu, there’s a part of VHOSTS, you can set that to “NO”. So you get a directory based setup. And if you set it to “YES” then you get a subdomain setup.

    The last thing needs a DNS wildcard in youre host his DNS setup.

    And in the Apache configuration add the following line in virtual domain setting:

    ServerAlias *.youre-domain.com

    But most webhosting companies dont allowed you to do so, so i suggest that you will use a directory based setup ;-)

    Suc6!

    Avatar of Dainismichel
    dainismichel
    Participant

    @dainismichel

    The directory-based setup, installed into the root directory of subdomain.domain.org, ran into a redirect loop error (WP MU issue), and I unfortunately see no way to install buddypress right now because of it.

    Avatar of Felix2009
    Felix2009
    Participant

    @felix2009

    Then you make some where in youre install a error ;)

    Avatar of Dainismichel
    dainismichel
    Participant

    @dainismichel

    I was installing by following the instructions here http://codex.buddypress.org/getting-started/installing-buddypres-from-combo/ exactly.

    I really don’t know how it happened, but I forgot to create a new database, and I started the sequence from the beginning, and it worked (over an existing DB).

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.