Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problems with 0.9.7

  • Avatar of hayleyc
    hayleyc
    Participant

    @hayleyc

    Hi,

    I’m a really big fan of this plugin and have been using it for a couple of months. However, I’ve just updated to 0.9.7 and I’m now having all sorts of problems, many of which seem to have also been raised on other threads. Unfortunately I’m struggling to get any of the suggested fixes to work. Issues include:

    – php warnings (I’m not sure how to switch off warnings?!)
    – I can create lectures, but clicking the button to view course lectures displays the ‘cheatin uh’ error
    – Can’t create assignments – get the ‘cheatin uh’ error
    – Can’t update the course description – again, get the ‘cheatin uh’ error

    I’ve tried deleting and then reinstalling the plugin, and recreating the group, but it doesn’t seem to fix it.

    Is there a new update due soon to fix these things, or any kind of solution you could point me towards? If not, can you please point me to where I can download previous versions of the plugin so I can reinstall the working version?

    Thanks :)

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    Warnings can be switched off by adding: `ini_set(‘display_errors’,’off’);` in your `wp-config.php`. It’s my fault cause this got out.

    For the rest…
    Looks like there’s an issue with permalinks.
    Go to your permalink options page and hit `Save` to flush the rewrites.

    There’s no update planned, there’s also no other download, something is broken with your installation!

    Avatar of hayleyc
    hayleyc
    Participant

    @hayleyc

    Hi Stas,

    Thanks for your help. I’ve switched off the warnings, but I’m still having the same problem with the ‘all lectures’ button, creating assignments and updating the course description. I clicked save on the permalink options page and also tried deleting the group and creating a brand new group. Any thoughts on how else I could fix my installation? It was definitely working before the latest update!

    Thanks :)

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    This is really weird, since no changes were made to code responsible for saving pages.
    I’ll test it out and get back to this.

    Avatar of hayleyc
    hayleyc
    Participant

    @hayleyc

    Hi Stas, just wondering if you’ve come across anything that might have caused this, or suggestions for fixing it? Really hoping I can get this plugin working again. Thanks.

    Avatar of hayleyc
    hayleyc
    Participant

    @hayleyc

    Hi @sushkov, I’ve been looking at the error logs for this problem as it’s still occurring. The following errors are occurring when I try to upload an assignment, can you please help me work out how to fix them? Thanks very much.

    PHP Notice: Undefined property: BPSP_Assignments::$current_lecture in /var/sites/r/***/public_html/wp-content/plugins/buddypress-courseware/lectures/lectures.class.php on line 203

    PHP Notice: Trying to get property of non-object in /var/sites/r/***/public_html/wp-content/plugins/buddypress-courseware/assignments/assignments.class.php on line 378

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.