Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problems with .htaccess

  • Avatar of MeisterYoda
    MeisterYoda
    Member

    @meisteryoda

    well, i started testing buddypress on my localhost (XAMP) and everything works great. Then i made an installation on my VServer and now i have problems with .htaccess.

    If i delete .htaccess the site comes up, but every link is 404.
    If i change Permalinkstructure and create a .htaccess i get an 403


    Forbidden

    You don’t have permission to access / on this server.
    Apache/2.2.3 (Debian) mod_python/3.2.10 Python/2.4.4 PHP/5.2.0-8+etch16 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at http://www.mydomain.com Port 80



    anybody an idea how to fix it?
    thanks in advance
    Peter

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Bowe
    Bowe
    Participant

    @bowromir

    Create a new file in your root folder called .htaccess and put the following code in it (assuming you’re using a single WP install, not MultiSite)

    `
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    `

    Save the file and make sure it can be read by the server (chmod 644 I think). That should do the track if you have set up your permalinks properly (/category/postname in my case)

    Avatar of MeisterYoda
    MeisterYoda
    Member

    @meisteryoda

    thank you Bowe.
    but it didn’t fix my Problem. Only an empty .htaccess works without a permission-error. Well, is it possible to change the linkstructure for buddypress? for example index.php/activity/ instead of /activity/ ?

    Avatar of MeisterYoda
    MeisterYoda
    Member

    @meisteryoda

    sorry… i forgot.
    The error also exists in case i deactivate buddypress und change to wp default theme.

    Avatar of MeisterYoda
    MeisterYoda
    Member

    @meisteryoda

    ok, i hope it solved my problem permanently…
    I check in confixx my domain settings… mod_rewite was checked, but in my web.1.conf it wasn’t loaded, so i put the line:
    `LoadModule rewrite_module modules/mod_rewrite.so` at the end of the document and restarted apache. Now it works…

    During restart i get the warning, that mod_rewrite can’t loaded twice… but, OK, it works…

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.