Skip to:
Content
Pages
Categories
Search
Top
Bottom

Profile Avatar Showing Wrong Image

  • Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    I’m on Buddypress 1.8.1 and WP 3.6. An old profile image from a user that deleted his profile is showing up as new member profile images.
    I have located the avatar upload thumbnails in wp-content/uploads/avatars and located the image that is being inserted by accident in folder 10.
    Anyone else encountered this bug?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    Should deleted member profile avatars remain in the wp-content/uploads/avatars folder? It seems like the old avatar folders are not being deleted so when a new member signs up the old image remains and is automatically shown in their profile.

    Could this be some type of permission issue with my old avatar files not being deleted? I am not familiar with where to check the error log so some advice is welcomed.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @catwomanbadkitty Contact host tech support re where your error logs are. Have you cleared cache? If you change to BP Default theme, does same issue show up? Site URI where issue shows up?

    Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    Thanks for the reply. I am on a VPS with Digital Ocean so I don’t have a control panel. I will put in a support ticket to see if they can help me find the log file using FTP or from the command line.
    Regarding clearing the cache, do I have to install a caching plugin for that or is it possible to clear cache from dashboard?
    I tried the registration process from the default Buddypress theme and it happened again. The new user is picking up one of the existing avatar upload folders and inheriting the image by default. The old image appears in the profile before I even get a chance to select a new profile image.
    The site is in maintenance mode but I will leave it open for now. Here is one of the new profiles that is inheriting a test image: http://www.uberon.net/goblinqueen/
    Thanks for your feedback!

    Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    I would like to ask my original question again because it still hasn’t been adressed: When a member deletes his or her profile, are the avatars supposed to remain in the folder:
    wp-content/uploads/avatars
    Or are they supposed to get deleted out?
    Is it possible that they are not being deleted due to permission errors on the avatars folder?

    Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    Still trying to solve this issue. I made sure this was not an ownership or permission error by doing some work from the command line in Putty. So that is not the problem.
    I am unsure why I am supposed to clear my cache. If you meant my browser cache then this doesn’t make sense because the avatar files are not being deleted from the server. I have only 5 users at the moment and over 15 avatar folders with images from old test users.
    If you meant using a caching plugin then the ones that I have looked at are for blog and comment caching and don’t mention avatars. I think the caching plugins are only for database entries. Avatars are uploaded to the server and remain there.
    So again, if anyone knows if the old deleted user avatars are supposed to be deleted automatically when a user deletes their account, please weigh in. I would appreciate it!

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    I don’t think avatar folders are deleted when a user deletes their account.
    But that shouldn’t matter because avatar folders are based on user_ids which are auto-incremented.

    Are you saying that all new members end up with the image in this folder:
    /wp-content/uploads/avatars/10

    Do you have the same image selected as the default avatar under Settings > Discussion ?
    Try changing that setting.
    Try deleting the ‘over 15 avatar folders with images from old test users’
    Try clearing your browser cache

    Avatar of catwomanbadkitty
    catwomanbadkitty
    Participant

    @catwomanbadkitty

    The Mystery Man image is selected in Settings > Discussion.
    What is happening is that Buddypress is assigning a new user id # to new members but the folder for that user id # still exists so they are inheriting an old image avatar. When they go to upload their avatar for the first time the old deleted profile image appears instead of the Mystery Man image.
    I suppose a quick fix is to FTP into the wp-content/uploads/avatars folder and delete out any of the deleted user folders so that this doesn’t happen.

    I would think that Buddypress would delete these old avatar image folders when users or admin decide to delete a profile. When plugins are deleted the folders are deleted from the server so I am not sure why the avatar files should be any different.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.