Skip to:
Content
Pages
Categories
Search
Top
Bottom

Profile page, Forum tab: Sorry, there were no forum topics found.

  • Avatar of xcentriq
    xcentriq
    Member

    @xcentriq

    Hey guys,

    I’m running the WP 3.3.1 and BP 1.5.5 with bbP 2.0.2.

    In the profile page and under forums tab, I’m getting this message:

    Sorry, there were no forum topics found.

    I’ve setup categories and forums/sub-forums correctly and have test topics and test replies in it to see if that would show up but it doesn’t. I just get the above message.

    How can I fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of relachola
    relachola
    Member

    @relachola

    I think this is a bug. I have been facing this issue for a very long time and raised it on this forum and reported to buddypress as well but with no solution as yet. If you try creating a topic under the forum as an non admin user, you might get an error as well.

    Avatar of tdoubleu
    tdoubleu
    Member

    @tdoubleu

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Check that you have a bb-config file in your root directory and that it has the same details as wp-config for accessing the DB, if you haven’t got one perhaps you actually didn’t set up forums in the BP setup? in which do so if you did then you may need to manually copy over bb-config to your doc root and then go back to a group select ‘admin > settings’ and ensure ‘enable discussion forum’ is checked and save the page.

    Avatar of mrlobaloba
    mrlobaloba
    Member

    @mrlobaloba

    i don’t see the tab forum in my profile buddypress!!! O_o

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    There are now four different poster to this thread! Please observe basic and essential forum nettiquette by not posting in others threads as your issues while similar may not be a mirror of the original posters question/issue and multiple responses can’t be maintained within one thread as it’s too confusing.

    Ok I see my problem here. I don’t have a bb-config.php in my root directory. When I find the bb-config, it’s in “wp-content/plugins/buddypress/bp-forums/” AND “wp-content/plugins/buddypress/bp-forums” and the file says:

    ***
    * *** IMPORTANT ****
    * This file will stop people from accessing your bbPress installation directly.
    * It is very important from a security standpoint that this file is not moved.
    * Your actual bb-config.php file will be installed in the root of your WordPress
    * installation once you have set up the forums component in BuddyPress.
    */

    //header(“HTTP/1.0 403 Forbidden”);

    So in there it says that my actual bb-config is located in my root dir, but I actually don’t have one there. Can I just copy that file over to my root or can I duplicate wp-config and rename to bb-config? Or is there more to it?

    I think I didn’t have the bb-config in my root cause I had previously installed bbpress and I clicked on use existing installation. I uninstalled it and reinstalled it via buddypress and now I’ve got one. I’m yet to check the details against wp-config. Will update here!

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    it’s something I’ve mentioned a few times on threads of this nature, you need bb-config in your root next to wp-config if the BP group forum install doesn’t move it then copy it over and ensure it has same DB details as wp-config

    Hey Hugo,

    I’ve got the bb-config next to wp-config in the root dir. Checked all DB settings and they are matching. Still getting the issue though.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.