Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Question about after installing Buddypress!!!!

  • Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    Hey

    I have a CMS wordpress account for my website which is hosted in GoDaddy with a paid domain name. I tried to install BuddyPress plugin but after I installed it idk what to do. and how to create forums or let other users to register in my forum
    I mean how can my forum be like BuddyPress foum?

    please help me

    ty

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of bp-help
    bp-help
    Participant

    @bphelp

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    Thanks for ur reply!

    I tried to do what it’s saying in the link and this is what I got http://www.techknowledgic.com/forums

    idk what’s going on I can’t create topics or let the visitors to log in or do anything please help me to set up the forum

    BTW, my website is still under construction so the menu and the content are just random and don’t take it seriously :D

    ty

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    - What did you create – Group Forums or Sitewide Forums or Sitewide/Group forums?
    - Click on the phones forum, there should be a form where you can create a topic for that forum.
    - Did you enable registration in your site via Settings > General ?

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    Thanks for ur reply!

    1-I create sitewide forum as written here http://codex.buddypress.org/user/setting-up-a-new-installation/installing-group-and-sitewide-forums/#a-set-up-sitewide-forums-only but without the bbpress group part because I only want forum and not groups

    2-Yes I can create topics now maybe there was something wrong before

    3-Yes its enabled and I still can’t register or log in

    ty

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    Any help guys?

    I am sorry I am just bumping the thread but I really need to solve this issue ASAP and run the forum to start running my website because it’s the only problem left

    ty

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @techknowledgic re your #3 answer – do you mean that even you cannot log in or that only users cannot log in? If you deactivate bbPress, can you/users log in or register?

    Going back to basics. Did you by any chance create your WordPress installation via webhost’s script i.e., via GoDaddy WP one-click install? If so, that’s not going to work with BuddyPress, see http://codex.buddypress.org/user/before-installing/

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    I tried to deactivate bbpress and the forum got deleted and the page which is mywebsite.com/forums became not available and giving 404 error and when I activated it again it worked again and in both cases I can’t see log in or register or anything in the page

    and about the second question actually there was someone that was developing my website and he is done now with the website and now I am just trying to fix some issues with it before I launch it so idk if he used GoDaddy or not but when I log in to my admin area I see this message “Go Daddy Quick Setup ™
    Build your WordPress site in just a few clicks.

    Get Started No thanks, I’m good.” and sure with pictures and stuff but this is in general so maybe he didn’t use GoDaddy and also I have an FTP account to upload files or images but I just edit my site by the admin area mywebsite.com/wp-admin

    and here is the link of the forum if you wanna check it clearly and see the details http://www.techknowledgic.com/forums

    ty

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I log in to my admin area I see this message “Go Daddy Quick Setup ™

    More than 5 years since I used GoDaddy, when you say admin area, are you referring to the GoDaddy admin area or your WP install’s admin area? If in WP install admin area, then there’s an issue. Otherwise, let’s move on.

    I am just trying to fix some issues with it before I launch

    I don’t know what aspect of your site was developed by the person you hired.
    - Note that your avatar at http://www.techknowledgic.com/members/techknowledgic/ is showing up humongous in Chrome.
    - And the avatar under freshness in Forums index page is showing too big.
    - Why is #.Ue8yX43rw80 appended to your forums slug when I go http://www.techknowledgic.com/forums/ ? strange.
    - Let’s test. Create a new Page named Discussions and place the forums shortcode there. Go to Settings > Forums and change archive slug to discussions. Then go to technowldgic.com/discussions/ and check out your forums

    Going back to logging in. I added the bbPress login widget to the sidebar of Twenty Twelve theme and it’s working fine even with BuddyPress activated. What are you using for your users to log in?

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    I mean in the WP admin area and I see it in the dashboard

    and about the pic I have asked a question yesterday about re sizing the pic size in the forum http://buddypress.org/support/topic/how-to-resize-memebrs-images-sizes/

    idk what’s going on with me and why nothing is working

    and about the weird characters also they are available almost in all the pages like the contact us for example it ends with #.Ue-C0PnI1FM I thought that it’s normal but I will check this out with the developer if he solve it

    - Let’s test. Create a new Page named Discussions and place the forums shortcode there. Go to Settings > Forums and change archive slug to discussions. Then go to technowldgic.com/discussions/ and check out your forums

    I tried this and after saving the setting the forum page became 404 error page and also I am seeing this error near the box where I wrote discussions “Possible bbPress conflict: Topics base” so I removed it and wrote forums and topics again in the archive slugs

    Going back to logging in. I added the bbPress login widget to the sidebar of Twenty Twelve theme and it’s working fine even with BuddyPress activated. What are you using for your users to log in?

    I don’t think I am using anything, I thought everything would come with the buddypress plugin like the log in area and everything else. what should I use?

    and I am so sorry for asking too many questions and having too many problems but idk why I am so lost by installing the forum

    and ty so much for ur help

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    I think now it’s better because my website developer helped me with it http://www.techknowledgic.com/forums

    but if a visitor wants to register do they have to register with wordpress to be able to log in to my site? I mean I can’t have my own registration area?

    ty

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    Guys I fixed most of the problems so far but I still have small issues :D

    1-the size of the image is becoming very big and the quality much less so I need a solution for this issue

    2-There is a log in area but there is not registration area http://www.techknowledgic.com/forums

    Thanks guys for ur help :D

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    about the size of the images I think it’s a CSS problem and I will try to get I solved

    about the second problem I found the registration page but there is no registration button

    here is the log in page or the main forum page http://www.techknowledgic.com/forums

    and here is the registration page which I found it after I click on the log in which I will be redirected to this page http://www.techknowledgic.com/wp-login.php and then I have to click register and I go to this page http://www.techknowledgic.com/buddypress/register

    so please guys anyone can help me get the registration button to the maain forums page?

    Thanks!

    Avatar of Techknowledgic
    Techknowledgic
    Participant

    @techknowledgic

    I solved the registration issue. It was just a widget and I didn’t know that :P

    anyways just one simple issue is left which is when I try to comment on any activity in a member’s profile the page directly refreshes and I can’t comment

    and I have already asked that question here but there is no answer so if you can help me here or there http://buddypress.org/support/topic/the-page-refreshes-when-i-comment-help/

    BTW, it’s not a bump but just saying that I have solved the registration issue and sharing my other problem here at the same time

    ty

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.