Skip to:
Content
Pages
Categories
Search
Top
Bottom

"Read more" not working on group activities

  • Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    Hello :)

    I have a little problem with my group activities, when we click on the “read more” at the bottom of the page, nothing happens.

    The “read more” button is working well on profile activities, I don’t know what I did wrong…

    Can someone help me please?
    I don’t know where to look, which file is concerned?

    Thank you very much ^^

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @doremdou BP/WP versions? Have you tried some basic troubleshooting like changing theme to Twenty Fourteen theme?

    Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    Hi @mercime thank you very much for your answer :)

    sorry, I am always on the last version: BP 2.0.1 and WP 3.9.1

    I tried what you said and I am so sad…
    The problem is indeed coming from my theme :(

    I have two problems coming from my theme with buddypress and activities…
    - The read more button on group activites is not working
    - and when we click on “delete” on a activity message, it does not work and display a 404 error page.

    With the twenty fourteen theme it is working fine…
    Where should I look what is wrong with my theme?
    Thank you very much for your help :)

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @doremdou What theme are you using? Perhaps you need to upgrade your theme. If it is a premium theme, you can ask if the theme is compatible with BP. You could also check if the theme is enqueueing its own jquery and not the jquery version used by WP.

    Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    @mercime hi again :) I am using a free theme,hueman.
    I can’t provide a link to my site :/

    I have tried saving the permalinks but didnt change anything,
    Do someone know which files are causing those things to not work? is there any way to find if a file is not called properly on a page or something like that? I am lost and don’t really know where to look…

    Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    Hi :)
    Does anyone has an idea for this?

    I tried to contact the theme developper but I think he does not answer questions like this one anymore, I can understand him but I don’t really know how to fix this without help…

    I don’t really know where to look, which files are concerned?
    thank you very much

    Avatar of danbp
    danbp
    Moderator

    @danbp

    hi @doremdou,

    BP is a few steps away from better js handling, wich can be the cause of your current trouble.

    https://buddypress.trac.wordpress.org/ticket/5735

    Maybe open a ticket and describe the problem ? ;-)

    Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    Hi @danbp thank you for your answer :)

    Should I open a ticket and describe the problem with my specific theme?
    Won’t they tell me to ask the theme developper for help as this is a buddypress website?
    I see it has something to do with theme and buddypress conflict/compatibility somewhat, but I am not sure I will be clear enough to explain the problem
    Sorry I don’t really understand all of this ^^

    Well I thought of another fix for my problem, is this possible to disable the “load more” button and activate pagination for activities?

    I saw something like that in (old?) code the other day:
    ” <?php /* Show pagination if JS is not enabled, since the “Load More” link will do nothing */ ?> ”

    is this still used and how can I de/activate it? :)
    Thank you very much

    Avatar of danbp
    danbp
    Moderator

    @danbp

    i guess you have first to debug your theme. No worry about ticketing: hueman is a free wp theme.
    Is it up to date ?
    I use it and see no errors on groups activity or elsewhere.

    Read here fore some dev tips

    Avatar of Doremdou
    Doremdou
    Participant

    @doremdou

    @danbp really? you are using this theme and you can use the load more button on group activities?

    so something is wrong on my side… I removed all plugins, functions and child theme but the basic theme and group activities are still not working, will look at it a bit more…

    thanks :)

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.