Skip to:
Content
Pages
Categories
Search
Top
Bottom

Redirect without putting in full URL

  • The redirect for the first time works great, except we’re using a staging server and all that jazz and it won’t let me just put in ‘/members/USERNAME/ — I have to put in the full qualified URL — any way I can hack the plugin to make this a reality for me?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    If you mean that you don’t want to hard-code the url and still have it work for both a dev site and a production site, try:

    get_option(‘siteurl’) . “/members/USERNAME/”

    Thanks Shane, where would I drop that?

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Sorry, didn’t notice I was in a specific plugin forum…

    I’m guessing that the redirect url is an option on the admin page for the plugin ?

    You may just need to change it in wp-admin when you push it to production. Not so bad is it ?

    As for hacking the plugin – I will defer to the plugin creator -DJPaul.
    He’s around fairly often and can give much better advice.

    I was digging around in the code and found this…

    `$text = str_replace( “USER_URL”, bp_core_get_user_domain( $user_id ), $text );`

    I’m assuming if i put in http://USER_URL/members/USERNAME that it would work. Hopefully DJPaul is on here soon. :)

Viewing 4 replies - 1 through 4 (of 4 total)

The forum ‘Welcome Pack’ is closed to new topics and replies.