Skip to:
Content
Pages
Categories
Search
Top
Bottom

Register page and user page 404 error

  • Avatar of libationblog
    libationblog
    Participant

    @libationblog

    Ok so I have installed the latest version of WPMU and Buddy press. The main page is working fine when I try to setup a new account I get a 404 error. And oddly enough when I am logged in as admin and click on my name to see my profile I get a 404 error. Any thoughts?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Please answer these questions: http://buddypress.org/forums/topic.php?id=2674

    Avatar of libationblog
    libationblog
    Participant

    @libationblog

    No problem:

    1. Which version of WPMU are you running?

    2.7.1

    2. Did you install WPMU as a directory or subdomain install?

    directory

    3. If a directory install, is it in root or in a subdirectory?

    root

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    no

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    yes

    6. Which version of BuddyPress (BP) are you running?

    1.0.2

    7. Did you upgraded from a previous version of BP? If so, from which version?

    no

    8. Do you have any plugins other than BuddyPress installed and activated?

    no

    9. Are you using the standard BuddyPress themes or customized themes?

    standard

    10. Have you modified the core files in any way?

    no

    11. Do you have any custom functions in bp-custom.php?

    no

    12. If running bbPress, which version?

    no

    13. Please provide a list of any errors in your server’s log files.

    none

    Avatar of libationblog
    libationblog
    Participant

    @libationblog

    Here is one more thing I just noticed. My site is hosted on 1&1 on a developer account. I took a look at my .htaccess file which currently has the

    AddType x-mapp-php5 .php

    Command to force the server to use php5. When I add the text from the htaccess.dist

    RewriteEngine On

    RewriteBase BASE/

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]

    RewriteRule . index.php [L]

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off

    </Files>

    </IfModule>

    I get 500 errors. Any insights?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Make sure you have the bpmember theme in the proper place: /wp-content/bp-themes/

    Then, make sure you have it selected in WPMU’s backend by navigating to the BuddyPress menu grouping like this:

    BuddyPress > General Settings > Select theme to use for BuddyPress generated pages

    Choose the “BuddyPress Default Member Theme”.

    I took a look at my .htaccess file which currently has the

    AddType x-mapp-php5 .php

    Command to force the server to use php5. When I add the text from the htaccess.dist

    Also, concerning the .htaccess file. It will automatically be created for you during the WPMU install. So, if you went to it and did not see anything, then something went wrong with the install. Why did you have to add the text from htaccess.dist to your .htaccess file?

    Avatar of libationblog
    libationblog
    Participant

    @libationblog

    First off Jeff thanks for the help!

    The themes are in the correct place as you have indicated above. The BPHome theme is located in the wp-content/themes directory to feed the main site.

    When I did the install it didnt produce a .htaccess file. So I tried creating my own. Does this provide any insight?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Well, if you don’t touch the htaccess.dist, it should create the .htaccess file. It is an invisible file, so if you do not have your file browser set to view hidden files, you will not see it.

    Also, if as you’ve said you did a root install of WPMU, then this line should be:

    RewriteBase /

    and not:

    RewriteBase BASE/

    Avatar of libationblog
    libationblog
    Participant

    @libationblog

    I can see hidden files so thats not the issue.

    But, Jeff your other solution fixed everything perfectly. Thanks for the assistance!

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Great! I’m glad I could be of assistance.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.