Skip to:
Content
Pages
Categories
Search
Top
Bottom

Registration Captcha Verification

  • Avatar of m@rk
    m@rk
    Participant

    @mrk-1

    Does anybody have a clue how they implemented the Captcha Verification in the registration form at the BuddyPress Demo Site?

    This doesn’t seem to be included in the current SVN snapshot version. To me it looks like a more simple solution as configuring the WP-reCaptcha Plugin mentioned in another topic here?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Any normal WPMU plugin that actually ties into the signup process would work. I haven’t looked in awhile, but I am thinking it was probably found at http://wpmudev.org/plugins/ or from a search on WPMU support forums. Hopefully Andy will see the thread and tell us what plugin he used!

    Trent

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    the standard MU compatible reCaptcha plugin works like a charm

    Avatar of m@rk
    m@rk
    Participant

    @mrk-1

    Thanks Trent, I think Andy adapted WPMU-Signup-Captcha

    to add extra sign up fields you can use this action add_action( ‘signup_extra_fields’, ‘function_name’ );

    put the captcha code in the function.

    use add_filter( ‘wpmu_validate_user_signup’, ‘function_name’, 10, 1 ); for validation

    Avatar of Life2000
    life2000
    Participant

    @life2000

    I would very much like to to add the “Captcha field” to the registration form.

    The one Andy is using on this demo site is great. But I can’t seem to get there yet.

    Based on this discussion the right plugin could be this one: WPMU-Signup-Captcha

    However, it does not seem to appear anywhere after I upload the plugin.

    Any ideas please?

    Thank you so much;

    Vida

    Avatar of Life2000
    life2000
    Participant

    @life2000

    So, I have gotten the other plugin to work, this one -> “WP-reCaptcha”.

    But I think the one Andy is using on this site, looks so much better.

    Any ideas if we can get there?

    Thank you so much;

    Vida

    Avatar of m@rk
    m@rk
    Participant

    @mrk-1

    Verify to just simply upload the wpmu-signup-captcha.php in the mu-plugins directory (not in the plugins directory) !?

    Avatar of Life2000
    life2000
    Participant

    @life2000

    Hi Mark,

    I still can’t see any settings option or a place where I can include Captcha field on the profile page at the time of registration.

    Any ideas?

    Thank you so much.

    Vida

    Avatar of m@rk
    m@rk
    Participant

    @mrk-1

    Just upload the wpmu-signup-captcha.php in the mu-plugins directory. Then the captcha appears automatically in your registration form.

    Avatar of Life2000
    life2000
    Participant

    @life2000

    Hi Mark:

    Thank you for replying. That’s exactly what I did. The folder in MU Plugin. But it does not appear anywhere at all :(

    Vida

    Avatar of bikerjeg
    bikerjeg
    Participant

    @bikerjeg

    For those of you who haven’t figured out how to get the plugin working here’s some quick details I figured out after installing this myself.

    1. When you download the WPMU-Signup-Captcha from WPMUDev you’ll get three files that you’ll need to dig out of the directory structures wp-captcha.php, wp-captcha.tff, and wpmu-signup-captcha.php.

    2. wpmu-signup-captcha.php belongs in wp-content/mu-plugins

    3. wp-captcha.php and wp-captcha.tff are supposed to be placed in the root directory of where your wordpress MU installation is running from.

    Good Luck!

    I have buddypress 1.1 installed and it seems to work perfectly except for spammers or sploggers or whatever..

    I downloaded WPMU-Signup-Captcha from WPMUDev and put the 3 files in the directories, just like you said.

    I don’t see it in the plugins section of the admin, and I still don’t have any captcha applied to new registrations.

    Avatar of lukabernardi
    luka.bernardi
    Participant

    @lukabernardi

    Same problem.

    Other plugins I had problems with permissions on files, but even after setting all permissions to 0777 still not working

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.