Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] BP-columns: cant get pages to display in footer Unless logged in as admin.

  • Avatar of jamieh05gmailcom
    jamieh05@gmail.com
    Member

    @jamieh05gmailcom

    Hi Hope someone can help i am a little stumped here, i have buddypress installed and can only view my footer pages when logged in as admin.

    If i log out they disappear from view, even if i type in the url i get a 404 error. If i then log in as admin they show up and the text is displayed.

    I have a custom menu set up in wordpress, Appearance – menus, labelled as footer.

    I am running a custom theme with bp-columns.

    I was wondering if anyone could point me in the direction of how to get them to show up all the time as the pages are for terms, privacy, blog, about us etc. I am not a programmer so please be patient. Any help much appreciated.

    Thanks

Viewing 14 replies - 26 through 39 (of 39 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @goldbrick very strange, you said you deactivated all plugins except BuddyPress.
    - If you have bp-custom.php in plugins folder rename that to deactivate
    - if you have an mu-plugins folder, rename that to deactivate

    I was going to check source and styling but I’m getting a “500 Internal Server Error” from your site right now.

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    Hi Mercime

    yes i had an issue with my index.php file which is sorted now and the site is back up, i will have a look and see if i can find the 2 files, i did deactivate all the plugins except buddypress last time. i will try it again.

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    i have just checked and i dont have either of these

    - If you have bp-custom.php in plugins folder rename that to deactivate
    - if you have an mu-plugins folder, rename that to deactivate

    i have the site hosted on a VPS server does this make a difference?

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    hi mercime

    Dont know if this helps but i got the pages to show in the footer now by creating the custom menu, but the pages still show a 404 error unless i am logged in as admin. are pages hidden or restricted in buddy press until logged in.

    Jay

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == i got the pages to show in the footer now by creating the custom menu ==

    Yes, you’re supposed to create the custom menu in Appearance > Menus as I mentioned in posts above
    http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/cant-get-pages-to-display-in-footer-unless-logged-in-as-admin/?topic_page=2&num=15#post-94793
    http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/cant-get-pages-to-display-in-footer-unless-logged-in-as-admin/?topic_page=2&num=15#post-94911

    == but the pages still show a 404 error unless i am logged in as admin. are pages hidden or restricted in buddy press until logged in. ==

    Looks like there was a redirect for a split second to sportzmoney.xn.com or something of that sort. Where did you download the bp-columns theme? Should be from WP repo.

    Change theme to bp-default to check if Pages are still redirecting to 404

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    Just tried it in bp-default theme and i get the same outcome, 404 errors on thoses pages until i log in as admin.

    Not sure where the current theme came from it was customized by a previous developer.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == 404 errors on those pages ==

    The weird thing is that links to the BP components pages like forums and groups are working while your regular WP Pages are not working.

    Wait, did you make those Pages > “Private” in Page Write/Edit Panel? That’s one scenario which could cause that behavior.

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    ==The weird thing is that links to the BP components pages like forums and groups are working while your regular WP Pages are not working.==

    ==Wait, did you make those Pages > “Private” in Page Write/Edit Panel? That’s one scenario which could cause that behavior.==

    Just checked this all pages are public, very strange don’t get this at all?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    1. Did you “Publish” those pages already or are your pages “Draft”? If already published, click on Update Button on each page. Re-run Settings > Permalinks and save. Post content of your htaccess file here.

    2. Do you have a membership plugin or something like User Access Manager (UAM)? Deactivate and delete. Clear cache and check if Pages still redirect to 404.

    3. Go to dashboard > Tools > Export > XML.
    Create a free WordPress.com account
    In dashboard of your new WP.com account, dashboard Tools > Import WordPress WXR i.e. XML
    See if Pages appear even when not logged in. Then go to Tools > Export > XML
    If so, import the XML file into your install. If the pages are working in your WP.com, it should work now in your own install
    – Delete the free WP.com account (unless you want to keep it.

    If that doesn’t do it, answer this:

    http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/when-asking-for-support/

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    Hi Mercime

    Here is a copy of our htaccess file. i will try your other suggestions and get back to you.
    `# BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress`

    thanks

    jay

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    Hey Mercime

    Tried as above, it worked when i exported the pages to wordpress.com, but when i imported them back to sportzmonkey.com the page not found error appeared again. We haven’t got any membership plugin or something like User Access Manager (UAM), so i will take ago at the link you supplied.
    Thanks for all your help so far i will owe you a drink when its sorted.
    Jay

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    managed to sort it out thanks for all your help.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @goldbrick Glad the pages finally showed up. It would help to know what your solution was so that others who might have the same problem could be helped as well.

    Cheers.

    Avatar of goldbrick
    goldbrick
    Member

    @goldbrick

    i had a caching software installed on my server to help with speeding up the site. asked the host to de activate it and that seemed to work!!

Viewing 14 replies - 26 through 39 (of 39 total)

You must be logged in to reply to this topic.