Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] BuddyPress installed using WAMP server but links don’t work

  • Avatar of Steve Tomich
    Steve Tomich
    Participant

    @bstast

    Hello,

    I searched all over the site and couldn’t find the answer to my question. I have WordPress installed on my local computer using wamp server and I was able to get the buddypress plug in installed but no links work. If I am testing the site on localhost/wordpress and everything seems to be there but as soon as I click on any link, like the about or profile I get

    “404 Not found The requested URL /wordpress/about/ was not found on this server.”

    What am I missing?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of stwc
    stwc
    Participant

    @stwc

    I do dev on XAMPP on Windows, no problem, but I do use http://localhost.localdomain, which (if I remember correctly) was a necessary thing for WPMU.

    Not sure if that might be connected to your problem.

    Avatar of Steve Tomich
    Steve Tomich
    Participant

    @bstast

    stwc,

    Thank you for the reply but its a no go. When I click on any links at all my browser goes to the link directory that doesn’t exist I think. Also I am using WordPress not MU. What am I doing wrong?

    Avatar of Travel-Junkie
    Boris
    Participant

    @travel-junkie

    Have you checked in your php.ini file if mod_rewrite is installed? Check for the # (or was it ; ?) before it. If it’s there delete it, then restart apache. It should work then.

    Avatar of Steve Tomich
    Steve Tomich
    Participant

    @bstast

    @Travel-Junkie,

    I am sorry but I don’t fully understand what you suggested. Do you mean wp-config.php ? I have a feeling it is not buddypress. I just installed another theme and the links don’t work on any themes.
    Also I re-installed wordpress and left the Permalink Settings as default and the links to themes work just fine as soon as I change the permalink to do “Day and name” or any other option the links in themes don’t work. This is my main problem I think getting buddypress working with my theme.

    Should I change something in the wamp server?

    Avatar of Travel-Junkie
    Boris
    Participant

    @travel-junkie

    No, it’s not WordPress. Personally I use Xampp, so I’m not familiar with Wamp. Somewhere in your Wamp files there will be a file called http.conf. That’s the apache configuration file. There you can control what modules are being loaded by your test server. Look for that file, open it and then look for this line

    `#LoadModule rewrite_module modules/mod_rewrite.so`

    and remove the #

    Then restart Apache.

    Sorry about the php.ini reference in the post before. Mixed that up…

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Although not necessarily the answer to the problem I suspect that you are not using Apache vhost containers if not they do make life much simpler as using vhosts ensures the site can function as a fully qualified domain albeit one with something similar to .com.dev and a suitable dns entry to point to that in your hosts file. with that set up and a suitable directory structure you can mirror a live production server set up.

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    @hnla VHOST is not required for wordpress but is required for wordpress mu/multisite in case you want them to function as subdomain.domain.
    @bstats
    You should do two things and the problem should be solved.
    1. Check Mod_rewrite is enabled or not(as @travel-junkie has pointed). If you are on wamp 2.0, you can left click on the wamp icon(in the quick taskbar, the half cirecle icon)->Slect Apache(from the menu)->Apache Modules->rewrite_module(If it is not having a tick, click over that). Refresh the wordpress page and check is it working or not.
    2.Once mod rewrite is checked you can try enabling/disabling permalink and resave it and Most probably it is going to work.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    @Brajesh I didn’t say it was required, but running vhosts in a local test environment is eminently sensible not just for WP.

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    @hnla
    I do run it, and my test box say http://box.dev :) but setting it up on windows is a bit of pain as it requires editing the host file of driver.
    I was just trying to clarify it for @bstats current case, it should(hopefully) be not an issue.

    Avatar of Steve Tomich
    Steve Tomich
    Participant

    @bstast

    I got it and it was so simple, thank you.

    I did this:

    1. Check Mod_rewrite is enabled or not(as @travel-junkie has pointed). If you are on wamp 2.0, you can left click on the wamp icon(in the quick taskbar, the half cirecle icon)->Slect Apache(from the menu)->Apache Modules->rewrite_module(If it is not having a tick, click over that). Refresh the wordpress page and check is it working or not.
    2.Once mod rewrite is checked you can try enabling/disabling permalink and resave it and Most probably it is going to work.

    I know this is an old thread, but I had the same problem and there was something just a smidge different about mine, so I thought I’d tack it on at the end here, for future generations who might run into the same issue.

    I’m running XAMPP on OSX. I’ve got vhosts set up.

    The problem manifested itself when I switched permalink settings. When I saved the change, WP told me to modify my .htaccess file; but it didn’t tell me what to put in it. I was very perturbed. After a bunch of testing I found that it actually *was* telling me how to change it, but it was under the fold, so I couldn’t see it without scrolling.

    Once I cut and pasted the suggested .htaccess code everything went swimmingly.

    Best of luck.

    Travel Junkie..good job.. It solve my prob…me too was getting an error!!

Viewing 12 replies - 1 through 12 (of 12 total)

The topic ‘[Resolved] BuddyPress installed using WAMP server but links don’t work’ is closed to new replies.