Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Run BuddyPress from Sub-Blog or blog ID 2

  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    New install – WPMU 2.8.5.2 subdomain install + BuddyPress 1.1.2 + bbpress installed via BuddyPress

     

    I cannot get run BuddyPress from blog ID 2 instead of main/primary site.

    The steps I’ve taken so far are:

    1. Installed WPMU in root http://example.com/ – working great.

    2. Created http://members.example.com/ (blog ID 2)

    3. Opened up wp-config.php and added

    define ( 'BP_ROOT_BLOG', 2 ); at bottom of wp-config file

    4. Installed BuddyPress then added Forums component

    5. Opened up bb-config.php to double check –

    `$bb->uri = “http://members.example.com/wp-content/plugins/buddypress/bp-forums/bbpress/”;

    $bb->name = ” Forums”;

    $bb->wordpress_mu_primary_blog_id = 1;’

    6. Changed theme in http://members.example.com/ to BP default child theme

    7. Clicking on Admin user link to BP profile page in blogID 2 renders 404 not found page in main site using regular theme.

    8. Created new user from http://members.example.com set as Administrator and link to this new user’s profile page still goes to http://example.com site which renders 404 page as well.

     

    What have I missed in trying to get BuddyPress to run from blog ID 2 totally?

     

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)

The topic ‘[Resolved] Run BuddyPress from Sub-Blog or blog ID 2’ is closed to new replies.