Skip to:
Content
Pages
Categories
Search
Top
Bottom

Saving Selection Field Issue

  • Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    I’ve been having this problem for a while and I have no idea why.

    When I go to edit my profile, whenever there is a selection field (be it a checkbox, selection box, radio buttons, etc), if I haven’t selected anything in the field I get the following error:

    “There was a problem updating some of your profile information, please try again.”

    The fields are set to “Not Required” so that’s not the problem.

    Has anyone else had this problem. I really need this fixed.

    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of Mark Schafer
    Mark
    Participant

    @markschafer

    I just discovered the same problem of getting the same “Please try again” when attempting to save a profile with empty not required fields. Also only One (the last) item selected in a Multi Select Box is being saved and displayed on the Pubic Profile page. Check Boxes do work properly and display all checked items on the Public Profile Page. I’ll enter this in the Trac later today unless someone shares some additional insight.

    Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    Okay great. Obviously our problems are slightly different, but hopefully they’re related.

    This is just a really major issue, and I don’t want to launch my site until this is fixed.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Versions please 1.2.1? Branch? Trunk?

    Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    WordPress 2.9.2

    Buddypress 1.2.1

    Avatar of Mark Schafer
    Mark
    Participant

    @markschafer

    @nick – I understand our issues are similar but not the same. Are you able to use the Multi – Select Box successfully? As I mentioned, if I select more than one option, only the item that is lowest on the list is saved and shown on the public profile. If I change the field to a Check Box, it works correctly and all items checked are saved.

    wpmu 2.9.1, bp 1.2.1

    Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    @Mark Schafer, and anyone else

    Oh okay, I actually hadn’t tried out the multi select box yet.

    I have that issue as well! It only displays the last one I’ve selected exactly as you said.

    And I just tested this from scratch.

    Installed wordpress mu 2.9.2, installed buddypress 1.2.1, and tested each of the fields and the error occurs for each of the selection fields, (except for the multi select box which does as Mark Schafer stated)

    have you made a ticket?

    Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    I posted the ticket here:

    http://trac.buddypress.org/ticket/2173

    Avatar of Mark Schafer
    Mark
    Participant

    @markschafer

    Thanks for posting the ticket. Once Andy chimed in I was waiting to see if this was a known issue. I see it’s already been fixed in the trunk!

    Avatar of Nick Watson
    Nick Watson
    Participant

    @nickbwatson

    Excellent!

    Avatar of acreifi
    acreifi
    Participant

    @acreifi

    The problem:
    multiselectboxfields cannot be saved by trying to save profile of a user.

    the errror-message:
    “There was a problem updating some of your profile information, please try again.”

    is still present in buddypress 1.2.3 and wordpress 2.9.2

    I need this function for releasing a webside !!!!!

    Avatar of mrjarbenne
    mrjarbenne
    Participant

    @mrjarbenne

    I’m having a similar issue (Profile includes 4 required textboxes and a dropdown selection menu). WPMU 2.9.2, BP 1.2.4. Deactivated any profile related plugins (profile privacy, Custom Profile Filters) with same result: “There was a problem updating some of your profile information, please try again.” BUT, even though the red error box pops up, and the profile seems to need editing (changes don’t appear and textboxes are still active), if I click on the profile link along the top, the changes I have made show up.

    Any suggestions on how I might be able to narrow this error down a bit further to help troubleshoot?

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.