Skip to:
Content
Pages
Categories
Search
Top
Bottom

Scheduled Posts failing and Out of Memory Errors

  • Avatar of mikehenrysr
    mikehenrysr
    Participant

    @mikehenrysr

    Two months ago I moved my blog 18 month old blog for the second time. I went from an initial setup using Thesis to a new setup using a modified Woo theme to accommodate Buddypress. We only have about 150 BuddyPress users registered and about 175 posts going back a year and a half.

    But since this was originally installed in 2.9 and then upgraded to 3.0.1, I’ve experienced two frustrating problems. Schedule posts always fail with the “Missed Schedule” error and once I get something posted, some of the RSS readers that are subscribed to the site get 500 errors. The 500 errors occur at the same time as an “out of memory” error is recorded in the server log. Occasionally, other activities will get a 500 error too. The error log says: (12)Cannot allocate memory: couldn’t create child process: /opt/suphp/sbin/suphp for /home/lab1018/public_html/index.php. It’s almost like my own blog subscribers are causing a problem on the website similar to a DOS attack. And there are only about 300.

    I host on a VPS with 768 MB of memory. All of this is very frustrating.

    A vendor helped install this WP/BuddyPress that I imported my blog into. Their idea is that the problem is caused by the data and plugins that I have installed, however at one time we turned off every plugin including BuddyPress and reproduced the memory problem. I’m not sure anything is configured properly. I’d be open to any suggestions or ideas, and I’d even be open to hearing directly from established BP / WP developers who might be able to quote me a price for solving. My email is mike@leadchangegroup.com and my site is http://leadchangegroup.com.

    Any help / ideas would be appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Whilst you say you have a VPS with 768 Mb of RAM, how much is allocated to PHP?
    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    If that doesn’t work, try setting it manually in php.ini via the ‘memory_limit’ variable.

    Avatar of mikehenrysr
    mikehenrysr
    Participant

    @mikehenrysr

    The php.ini file has:
    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 128M ; Maximum amount of memory a script may consume (16MB)

    And in wp_config.php the following settings exist (I don’t know why they’re different…)
    define(‘WP_CACHE’, true); //Added by WP-Cache Manager
    define(‘WP_MEMORY_LIMIT’, ‘640M’);
    ini_set(‘memory_limit’, ‘640M’);

    I installed the GD Press plugin to report info like this and it says:
    PHP memory used: 52.4 MB
    Memory Limit: 256M

    And, when I look at the PHP configuration in CPanel, it says the memory_limit is -1

    The php.ini file is in the top level directory of my hosting account and in the top level directory of my domain.

    Shouldn’t these all be the same?

    Avatar of mikehenrysr
    mikehenrysr
    Participant

    @mikehenrysr

    So no one has an answer? Anyone want to propose a project for fixing this for me? Email me mike[at]leadchangegroup[dot]com. I need this fixed.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.