Skip to:
Content
Pages
Categories
Search
Top
Bottom

Screen options in dashboard not opening after upgrade to BP 1.2.10 using WP 3.2.1

  • Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Hi,

    Screen options drop down, help drop down, select all posts, etc. are not active after upgrade to BP 1.2.10. Using WP 3.2.1.
    I have narrowed it down to buddypress plugin, all other plugins are off. With all plugins off, the functionality works. With buddypress on the functionality does not work.

    I have cleared cache etc.

    Hope you can help.

    Regards,

    Express

Viewing 14 replies - 1 through 14 (of 14 total)
  • Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Seems that JS is messed up on the wordpress admin interface, along with the issues above the editor doesn’t show content and I can’t switch between Visual and HTML view.

    I’m using the default buddypress theme and I now have no other plugins active. I also reset the plugins (active_plugins field) in wp-options table and then only turned on buddypress. I have not customised core code.

    Was previously running 3.2.1 and 1.2.9. I’ve upload/installed the plugin in various ways to make sure nothing went wrong.

    Seems a JS issue to me? As if wordpress required functionality has been overwritten. The buddypress admin bar dropdowns work.

    Is anyone else having this issues?

    Regards,

    Express

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Update: Tried BP 1.5 RC1 and the issue is still there. This issue must not happen in every install or else everybody would be commenting. I’ll look for something local to my environment or attempt to debug the JS.

    Regards,

    Express

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Figured this out. The admin bar was broken at “Notifications”, this stopped the page from loading fully and some JS for wordpress was not loaded. The data in the database looked ok, but there was a lot of notifications in the table as I deleted a lot of content/posts recently. Anyway I emptied the wp_bp_notifications table and it’s working now. Great!

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Very strange. I wonder how old notifications might have caused this problem. You don’t happen to have access to your server’s PHP error log, do you? It might help to see whether this is a problem with BP itself.

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    I do, and have a look a bit later and post.

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    After I updated to BP 1.5 RC1 error were from ” /var/www/wordpress/wp-content/plugins/buddypress/bp-members/bp-members-notifications.php”

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    I should have looked at the error log before! Errors were (lots of them, all for the same bp core file):

    With BP 1.2.10 – PHP Fatal error: Cannot access empty property in /var/www/wordpress/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php on line 63, referer: some web page etc.

    Seems to me that when bp-core-notifications.php queried the db for notification data it somehow broke and stopped outputting. The last word of the HTML output of the page was ‘Notifications’.

    BTW: Can’t edit post here, have to delete and add another!

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Hm. Your upgrade must not have completed properly. In BP 1.5 RC1, there is no file called bp-core/bp-core-notifications.php. That file, along with the files that called it, must be left over from your pre-upgrade version of BuddyPress. You might consider deleting the contents of the entire /buddypress/ directory, and then reuploading BP 1.5-RC-1’s files into that folder.

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    For 1.5 RC1 the file that had the error was “~/wp-content/plugins/buddypress/bp-members/bp-members-notifications.php”
    For 1.2.10 the file was “~/wp-content/plugins/buddypress/bp-core/bp-core-notifications.php”.

    I had the error first with 1.2.10 then tried and upgrade to 1.5 RC1, both versions had the same error but for different files.
    I happy that my contents of the entire /buddypress/ directory are correct for 1.5 RC1. I’m now using 1.5 RC1.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Sorry about that, I misread what you were writing. I understand now.

    Have you, by chance, turned off any BP plugins recently? I have a hypothesis that there are notifications in your database corresponding to a component that no longer exists (ie, because you disabled it). Or maybe you have shut off one of BP’s core components?

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Yes turned off a few:

    BuddyPress Privacy Component
    BuddyPress Profile Gallery Widget
    BuddyPress Profile Music Widget
    BuddyPress Profile Video

    Didn’t use them much but some data (not sure what exactly – it’s gone now anyway) was in the notifications table.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Very strange. Well, if the problem arises again, take careful note of what plugins you may have turned on/off around that time, and then post again here. Thanks for your patience.

    Avatar of expressionsinweb
    expressionsinweb
    Member

    @expressionsinweb

    Thanks for the help.

    Avatar of paparon
    paparon
    Member

    @paparon

    Hi

    FYI, I had the same error “Cannot access empty property… bp-core-notifications.php on line 63″. I’ve been experimenting with plugins so have installed, tried and uninstalled several. I’m not real knowledgeable about WP, BP or programming but your solution about emptying the wp_bp_notifications table worked for me too. I’ve been experimenting with different plugins than you. Hope this helps you guys figure out what’s wrong.

    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.