Skip to:
Content
Pages
Categories
Search
Top
Bottom

server response increased when loading avatars after hosting images on subdomain

  • Avatar of ntmedia
    ntmedia
    Participant

    @ntmedia

    To allow browsers more requests, i created a subdomain, set the root on wp-content/uploads and told wordpress under settings –> media the new full URL path. Now all images are served from the subdomain. Works fine.

    Also buddypress user-avatars are now received from the subdomain, but all pages including more then 2-3 avatars, have an server response over 4 up to 20 seconds.

    Error-log shows: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary.

    I fixed that endless loop by adding

    RewriteCond %{ENV:REDIRECT_STATUS} 200
    RewriteRule ^ – [L]

    to .htaccess. But the issue is still there.

    I also tried to change

    $bp->avatar->upload_path = bp_core_avatar_upload_path();
    $bp->avatar->url = bp_core_avatar_url();

    to

    $bp->avatar->upload_path = ‘wp-content/uploads’;
    $bp->avatar->url = ‘http://www.domain.de/wp-content/uploads’;

    in bp_core_avatars.php so buddypress will not use the subdomain. It works and avatars are served from wp-content/uploads-path but the server response is still the same.

    Any ideas why this happens and how it could be fixed?

    BP 1.6.1
    WP 3.4.2

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    hi @ntmedia,

    as you say nothing about your server, i assume you’re on a hosted service (1&1, oder sonstiger)

    A subdomain is a domain that is part of a larger domain who depending on DNS addressing. In your case, the problem is not the addressing, but the server velocity. If you have no access to the server settings, in other word to the root server, you have no chance to get rid of the situation.

    htaccess setting or changing BP code has no/or poor effect on the server speed.

    Most probably you are hosted somewhere and your WP is installed at the root of your domain, but not at the root of the server. Even if you install x subdomains, they are all attached to the root domain in the same cluster.

    Imagine that you’re in a house with x floors. And your domain is hosted at the 5th floor, apartment n°12. Your host attribute a part of his server(s) capacity to your apartment. Take also in mind that on the same floor, live other tenant. This is the common usage.

    You added a subdomain, OK, but this is like you added a room to your apartment.  The apartment is not bigger, it has only one room more. But by adding this room, you lowered automatically the performance of the allowed capacity. Try to run in one room and find the difference when you run through 2 or 3 rooms. Or more… ;-)

    To have your own apartment, you can use a VPS. To have your own floor or eventually your own (little) house, you can use a dedicated server or create your own server from hand.

    Now, if you want absolutly your pictures served from a subdomain, install them on another server. A kind of mini gravatar service. Perhaps a low-cost hoster if you have not too much weight to store. And play with the DNS settings to get this server attached to your domain.

    Avatar of ntmedia
    ntmedia
    Participant

    @ntmedia

    Thanks for your explanation @Chouf1 :)

    It is a managed server from german hoster strato.

    I try to fix it since 2 days and got a big headache! :) This site has really much images to load and the loading time for archive-pages go down to 1,1 sec from 2,0 since loading images from subdomain. Everything works fine except of bp members-loop and bbpress topics with more than 3 replies.

    I will try to remove the subdomain and hope it works like bevor. It`s better all sites loading in 2,0sec instead of some loading very fast and some needs forever.

    I have that sense it could be fixed but i do not get it!

    Avatar of ntmedia
    ntmedia
    Participant

    @ntmedia

    Please delete this topic/thread.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.