Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] some css trouble with buttons

  • Avatar of enquirer32
    enquirer32
    Participant

    @enquirer32

    I’m posting a link to an image of this issue -┬áhttp://ispy.it/bub7 (saves logging in etc)

    re Forum replies (and a few other places):

    As you can see the buttons are not spaced properly (see top button – Follow this) and there is also a button within a button (Post Reply) – can’t seem to change these too well – must be missing something.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of JRCDyer
    JRCDyer
    Participant

    @jrcdyer

    Unfortunately, the image isn’t much help. I created a temp account, which you can delete later (username: JRCDyer).

    In your bp.css, go to line 590, where it says:

    .standard-form div.submit {
    clear: both;
    padding: 15px 0px 0px;
    }

    And switch it to:

    .standard-form div.submit {
    clear: both;
    padding: 0;
    }

    Or remove the ‘padding: 15px 0px 0px;’ line completely. The padding of 15px is pushing your button down to the lower corner. By removing it, the button will remain centred within the ‘div.submit’ selector.

    Of course, if you wanted the box surrounding the button to be larger you could switch the padding to: padding: 15px;

    Hope this helps.

    Avatar of enquirer32
    enquirer32
    Participant

    @enquirer32

    Worked fine – thank you very much!

    Avatar of enquirer32
    enquirer32
    Participant

    @enquirer32

    Actually this didn’t work…! It turned out that this made the buttons disappear in IE7/8 (at least). So nobody could register, for example. I modified the CSS to this and now the button shows:

    <code>.standard-form div.submit {

    clear: both;

    padding: 0;

    }

    #signup_submit {

    border-style: none;

    }

    #group-creation-create {

    border-style: none;

    }</code>

    I’m working my way through where all the buttons show up…

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.