Skip to:
Content
Pages
Categories
Search
Top
Bottom

SSL too many redirects

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of rodtrent
    rodtrent
    Participant

    @rodtrent

    Try adding the following to the bottom of your buddypress/bp-loader.php file:

    remove_action( ‘bp_template_redirect’, ‘bp_redirect_canonical’, 2 );

    This will remove the canonical redirect hook that might be causing you some issues.

    Never, ever, ever edit any files that come with BuddyPress. That’s terrible advice.

    Avatar of rodtrent
    rodtrent
    Participant

    @rodtrent

    @djpaul – Unfortunately, that’s the only way it works. It doesn’t work in bp-custom at all.

    @rodtrent thank you, sadly that did not work, i have placed the code in line 484 right here:

    ` // Setup the BuddyPress theme directory
    register_theme_directory( );
    }
    }

    remove_action( ‘bp_template_redirect’, ‘bp_redirect_canonical’, 2 );

    // “And now for something completely different”`

    but I still have the loop. Could it be connected to the fact that this wordpress/buddypress installation is located in a subfolder?

    Avatar of aces
    aces
    Participant

    @aces

    Do you have any ‘privacy’ plugins or something like a redirect_to_forum() function in your bp-custom.php file such as in http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/too-many-redirects-in-chrome-404-in-ff-when-trying-to-accees-group-ater-update/ ?

    If so try disabling it / them as they may need updating / replacing *

    Hi @aces thank you for your input, I am using private buddypress that was refered to in thread you mentioned but deactivating all plugins except buddypress did not change anything. I have set up a fresh new buddy press installation to check if it is just my installation, but its the same there I added the code that rodtrent mentioned but that didn’t change anything as well. It looks like it is locked in a redirect loop between e.g. http://example.com/buddypress/groups/group1 and https://example.com/buddypress/groups/group1 because the link that is shown in the url field of the browser is http but all the other pages are properly loaded with https. I have changed the wordpress and site url to https.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.