Skip to:
Content
Pages
Categories
Search
Top
Bottom

Stop the Sploggers

  • Avatar of Ian Walters
    Ian Walters
    Member

    @ian-walters

    Help – I’m getting overwhelmed with sploggers.

    I have my main wordpress settings so that new users are automatically ‘blocked’ so that I can check them out before allowing them to post but somehow they are getting on to my BuddyPress pages and not only posting their garbage but also creating groups.

    Am I missing some setting in BP that I should know about?

    Thanks
    Ian.

Viewing 6 replies - 1 through 6 (of 6 total)
  • are you using recapthca? You should use this on comments and or registrtion. Should squash a few of those spammers.

    Or you could hold their comment for moderation and block those users and or ip address.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    Change your registration slug and everywhere you’ve linked to the signup page make sure it has a nofollow on it.

    Actually, changing your registration slug wont do much. The spammers will just find the page again and then youldd have to change your registration slug again.

    Its best to add capthca to your registration and to your comments.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    The spammers google for your registration page. If they can’t find it there….

    And I’m suggesting it as one to help – not the be-all end-all. ;) Do that in conjunction with other things and it does help. I could also argue how captcha doesn’t work well for human too I’m not a fan.

    But if you rename it and dont add and secrurity, they can find it again! It really does do much.

    Just use captcha, keep it up to date. Only all registered users to comment. Only allow someone who has a preapproved comment to comment.

    And you’ll be fine.

    Changing slugs doesnt do any good.

    Avatar of Ian Walters
    Ian Walters
    Member

    @ian-walters

    I use SI CAPTCHA Anti-Spam.

    I have “Comment author must have a previously approved comment” checked.

    I have “Hold a comment in the queue if it contains 1 or more links” set.

    the author must fill out name and email and they must be registered and logged in to comment.

    and I STILL get splogged!!

    I have selected that I should be notified when anyone posts a comment but I don’t receive the notification.

    With the same settings and same plugins my other sites don’t get splogged so I think it must be something to do with BP.

    Help!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.