Skip to:
Content
Pages
Categories
Search
Top
Bottom

strange admin address

  • Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    When users are signing up on BP, they’re getting the password emailed to them but it’s coming from a funky address, mysite@box387.bluehost.com. That is definitely not what I have on the WPMU backend. The really bad thing is that this address is getting sent to the spam folder for many people. How do I fix this? Thanks!

    I know this is a WPMU question but I can’t find the answer anywhere. Plus, BP people are the best. :)

Viewing 25 replies - 1 through 25 (of 27 total)
  • Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    bp_core_email_from_name_filter()

    bp_core_email_from_address_filter()

    Might be causing this in bp-core.php

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    I found those in the bp-core.php but I’m not sure what to do. Is there a way to hardcode those functions to the correct address?

    Avatar of Deuts
    deuts
    Participant

    @deuts

    I’m in bluehost as well. And I’m having the same problem. The email “from” address is simply not so pleasing to the eyes. Any help will be appreciated.

    Hi, I’m having the same problem as well. I get @box441.bluehost.com as my address. Is this in buddypress or wpmu? I read somewhere that pluggable.php was a file to change in wpmu but haven’t been able to figure it out. please help!

    thanks!

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    Wish I could help but I never found a way to change this.

    hey Chris,

    i just find this article below through bluehost tech support. Now we have to figure out where this code exists in WPMU and/or buddypress.


    http://helpdesk.bluehost.com/kb/index.php?x=&mod_id=2&id=231


    Problem

    Why do e-mails from my webpage come from < username > @ < box# > .bluehost.com when I have specified otherwise?

    Solution

    This is because our servers require you (or your script) to use a properly formatted, valid From: header in your email. If the From: header is not formatted correctly, empty or the email address doesn’t exist on our server, the from address will be changed to <username>@<box#>.bluehost.com. To stop this, you must change the script you are using to correctly use a valid From header.

    Examples of headers that should work would be:

    From: user@domain.com

    From: <user@domain.com>

    From: “name” <user@domain.com>

    Examples of headers that will NOT work:

    From: “user@domain.com”

    From: user @ domain.com

    Alternative for PHP Users:

    - You can also modify which account should be used when sending out using the mail() function. Inside the local php.ini file, you will find a line of code that looks something like this (around line 601):

    sendmail_from = mail@yourdomain.com

    Be sure to uncomment this by deleting the ‘;’ before the directive. Also, the account you use must be a valid created account.

    Avatar of Deuts
    deuts
    Participant

    @deuts

    @nickmu, I found that Q&A, the problem is, where do I put the php.ini file? From what I know, the php.ini should be placed at the same directory of the code that executes the (mail) function. So the big question is, where do I put the php.ini file?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Howdy. You don’t *put* the php.ini file. It *is* someplace. :)

    Try /etc/php.ini

    It’s somewhere on your server. May or may not be editable by you if you are on a shared host.

    There’s another option mentioned in that article. You can specify an email address that exists on the bluehost server. Don’t you get x number of email addresses with your account?

    hi burtadsit,

    I’ve tried editing the php.ini and my notification emails are still sending out as “myusername@box441.bluehost.com”. I’ve tried changing my outgoing email in Operational Settings in wordpress’s dashboard to an email that i’ve set up on bluehost but that’s not working either. It appears that a ton of people are having this same problem on bluehost. there’s gotta be a simple answer. could it be the pluggable.php file or some other file in wordpress that I can manually edit? I can’t launch my new site with buddypress until i resolve this.

    thanks in advance for your help!

    Nick

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I should just learn to *really pay attention* when Andy drops in with a suggestion. I looked at the message that started this thread. Lets see if his suggestion that those two hooks are the problem.

    In /mu-plugins/bp-core.php are two functions that hook and alter the email ‘from’ address and modifiy it.

    Comment out:

    In: function bp_core_email_from_name_filter()

    line #1150

    add_filter( ‘wp_mail_from_name’, ‘bp_core_email_from_name_filter’ )

    And comment out:

    In: function bp_core_email_from_address_filter()

    line #1165

    add_filter( ‘wp_mail_from’, ‘bp_core_email_from_address_filter’ )

    Try some test registrations and see if they still say that whacky address.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Speaking of Andy. Have you seen his latest avatar on testbp.org? No?

    http://testbp.org/members/andy/

    The dress code is getting kinda strict at Automattic don’t ya think? Matt must have heard the rumors about skivvies and fuzzy pink bunny slippers. Things are kinda laid back in BC but Andy was taking it way to far.

    Sorry Andy. Such is the price. Evidently if ya wanna play with the big boys you have to dress like them.

    yeah b, but i have to give him credit for originality…its the first avatar i’ve seen showcasing a bow tie so prominently.

    Thanks for the tips…i’m testing now…let you know how it goes

    I’m still not having any luck. Maybe I’m not changing the bp_core files correctly. If I wanted to have the email come from “A.i. Music” and the email “support@aimusic.com”…how would you recommend inputing this?

    thanks

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    All that commenting of code does is take out the bp fiddling with the from address. If everything goes according to plan and the phase of the moon is correct and you have mu configured correctly to use your selected email address and your host isn’t just blowing smoke at you, then it might work.

    What do the new email headers look like?

    burtadsit,

    I don’t quite understand what your suggesting i do with the bp-core file. what edits are you recommending?

    Thanks for your help

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    The edits I was talking about are in the reply above that begins with:

    “I should just learn to *really pay attention* when Andy drops in with a suggestion.”…

    burtadsit,

    I see the reply you are talking about and found the lines in the bp-core.php file but I’m still not sure what to do with it. I’m sorry but could you please me more specific on how I would modify it? I want to have emails sent form “A.i. Music” as “support@aimusic.com” thanks so much for your help!

    Comment out:

    In: function bp_core_email_from_name_filter()

    line #1150

    add_filter( ‘wp_mail_from_name’, ‘bp_core_email_from_name_filter’ )

    And comment out:

    In: function bp_core_email_from_address_filter()

    line #1165

    add_filter( ‘wp_mail_from’, ‘bp_core_email_from_address_filter’ )

    Try some test registrations and see if they still say that whacky address.

    I’m not sure if i replace those lines with my info or just delete them all together. I’ve tried replacing them and it didn’t seem to do anything. I know there are a ton of people on bluehost with this same problem

    has anyone been able to solve this?

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    I did what Burt suggested, commenting out those lines, and it helped slightly. The email now comes from the address I designated in the WPMU settings. However, the email says it is From: WordPress and not from my site.

    hey Chris,

    thats great news…how do you comment the lines out? I don’t understand the instructions.

    Does commenting out mean to erase the following lines?:

    function bp_core_email_from_name_filter() {

    return get_blog_option( 1, ‘blogname’ );

    }

    add_filter( ‘wp_mail_from_name’, ‘bp_core_email_from_name_filter’ );

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    OK. I just wouldn’t do anything with the code then. We don’t want to have everything stop working.

    burtadsit

    I’m sorry…i’m new to some of the web jargon. I’m a musician. I understand now what you guys mean re: commenting out. I commented those lines out and its still sending all emails from bluehost (not to mention..its taking about an hour to two to receive them.

    I’m sure there is a simple resolution but it seems to be over everyone’s head.

    Chris, what lines did you comment out? I’d really appreciate anyones help.

    I can’t have buddypress sending emails from a bluehost address to people that sign up on my site …not to mention it taking an hour to get their confirmations etc.

    Guys,

    I’ve got a solution!

    go to:

    http://www.callum-macdonald.com/code/wp-mail-smtp/

    and download this plugin:

    Download: Current Testing Version: 0.8.2, Released 14/Dec/2008

    activate the plugin and call up the “Email” page on your dashboard

    check: Send all WordPress emails via SMTP.

    bluehost users enter:

    “localhost”

    465

    check: Use SSL encryption.

    check: Yes: Use SMTP authentication.

    username: noreply@yourdomain.com [this is the important part...make sure to enter "noreply" and that you have an email setup up for this on your server]

    password: the password you set up for noreply@yourdomain.com


    you may be able to change other settings using those lines of the bp_core.php files but at least these emails will come from your domain now! YAY!

Viewing 25 replies - 1 through 25 (of 27 total)

You must be logged in to reply to this topic.