Skip to:
Content
Pages
Categories
Search
Top
Bottom

Strange behavior when updating course / Button Alignment

  • Using WP 3.0.5, BP 1.2.8, SP CW 0.16

    I’m having some strange issues with a freash install of Courseware. Three things are happening.

    First, when I create a group and enable courseware for the group, then click on the Courseware tab for the first time, the “At a Glance” course description is displaying the title to my most recent blog post. The post title also displays when I click on the “Update course information button”. Why would the most recent blog post title be used at the course title when I haven’t given the course a title or description yet?

    Second, when I do provide a title and description for the course and click Update, the info appears to be saved but when going back to the “Home” tab for Courseware, the “At a Glance” section still shows the title of the most recent blog post. Is this possibly a custom post issue?

    Thirdly, the “Update Course” button in the “At a Glance” section is not aligning properly. It seems as though the first bullet point is too long forcing the button to move down and then causing the “Create an Assignment” button to move to the left. Is there CSS I can modify to change the alignment padding/margin?

    Thanks for the help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    BP 1.2.8, SP CW 0.16 was not tested.
    WP 3.0.5 has poor support for multiple post types, the bug might be caused by that.
    I advice you to upgrade!!!

    Also to note, Courseware is a one man project right now, so It will not going to offer support for older versions of WP/BP. Right now the development focus is on WordPress 3.2.1/BuddyPress 1.5.

    For customizations, check the
    http://scholarpress.github.com/buddypress-courseware/handbook.html#configuration
    Search for `courseware.css` option

    Thanks for information. I resolved the title issues by clearing my cache and cookies. Seems to be working well now. The button alignment issue was resolved by wrapping the bullet text so it doesn’t push out the button over and down.

    By the way, I am using the version combination because I rely on a plugin for membership called s2member. It is currently not compatible with WP 3.2 and BP 1.5 RC1 so even if I wanted to upgrade to the latest CW, I can’t because of version incompatibilities.

    Avatar of peeld
    peeld
    Participant

    @peeld

    I have s2member…says here: http://www.primothemes.com/readme/3679/#rm-changelog

    It is compatible with wp 3.2+, is it BP 1.5 that is holding you back? I’m running it with Wp 3.2.1 and BP (not 1.5…yet!)

    Avatar of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    Yep, we are waiting for BuddyPress 1.5

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.