Skip to:
Content
Pages
Categories
Search
Top
Bottom

Suffusion Theme Compatibility Problems

  • Avatar of hughshields
    hughshields
    Participant

    @hughshields

    I would like to know if Buddypress 1.8.1 is compatible with Suffusion. I know that 1.8.1 is supposed to include theme support but I am having issues formatting the layouts of the core Buddypress component pages in Suffusion (groups, activity, members).
    I had the Suffusion BP Template Pack installed but Suffusion has quit supporting this template pack because Buddypress is now supposed to be theme compatible so there are many files missing.
    Please let me know if there is anything I can do to make my Suffusion theme work with Buddypress.
    If not can anyone recommend a good theme that has similar functionality.
    Thanks
    Hugh

    Buddypress 1.8.1
    Wordpress 3.6
    http://www.uberon.net

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @hughshields first thing, back up the theme folder in your server to your hard drive.
    – Deactivate the Suffusion Template Pack plugin
    – Delete the following folders, if any, from your Suffusion theme folder in server: /activity, /blogs, /forums, /groups, /members, and /registration

    http://codex.buddypress.org/themes/theme-compatibility-1-7/bp-17-upgrading-template-packed-themes/

    Avatar of hughshields
    hughshields
    Participant

    @hughshields

    Thanks for the reply. I did this already last night and tested Buddypress with the theme and none of the controls for Suffusion are working; formatting, layout, widgets…none of it works.
    I also tested this out on another test site where the same thing happened. So it appears that Suffusion is not compatible with Buddypress.
    I thought that with WordPress 3.6.1 template packs were going to be made obsolete. Does this not apply to Buddypress?
    The solution is to install the Suffusion Buddypress Pack but this pack is outdated and doesnt appear to be getting any support. When I asked about missing template files they told me on the support forum that template packs were not needed. So I’m going in a circle :)
    Any solutions or ideas welcome. Or maybe a recommendation for a better theme that works with Buddypress.

    Avatar of hughshields
    hughshields
    Participant

    @hughshields

    The Suffusion Buddypress Pack is built on the BP Template Pack but is still necessary in order to allow for theme functionality such as formatting, layout, widgets etc. The problem is that the template files are out of date and are from BP 1.6. This is causing problems with the pack.
    I downloaded the Buddypress 1.8.1 plugin to my harddrive to try and find updated template files but only see a folder for bp-legacy.
    Can someone tell me where to find Buddypress 1.8.1 template files or a way to remedy my problem with my theme.
    Much obliged.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.