Skip to:
Content
Pages
Categories
Search
Top
Bottom

Tags not attached to Topics posted via Forum Directory unless by admin user [FIX INCLUDED]

  • To replicate log into your Buddypress site which is using Group Forums (not Site Wide Forums) as a subscriber (not an Admin) go to the Forums Directory (not a Group’s Forum page) and post a New Topic with some tags. You’ll see the tags are not saved.

    Try the same, but posting the New Topic via the Group’s Forum Page and you’ll see the tags are saved.

    This looks like it was patched 6 months ago, but I’ve opened /bp-groups/bp-groups-classes.php and can’t see the patch so maybe it was never merged in? Ticket below.

    http://buddypress.trac.wordpress.org/ticket/3858

    Apply this manually fixes the issue.

    1. Which version of WordPress are you running?
    v3.4
    2. Did you install WordPress as a directory or subdomain install?
    in the http root.
    3. If a directory install, is it in root or in a subdirectory?
    http root.
    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    v3.3
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    Yes
    6. Which version of BP are you running?
    1.5.6
    7. Did you upgraded from a previous version of BP? If so, from which version?
    Yes from 1.5.5.
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Yes, but we’ve tried disabling all plugins and still experience the issue.
    9. Are you using the standard BuddyPress themes or customized themes?
    A customised theme, but we’ve tried reverting, and still experience the issue.
    10. Have you modified the core files in any way?
    No.
    11. Do you have any custom functions in bp-custom.php?
    Yes, but none relevant to this, and we’ve tried removing them and retesting.
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    Removed bbPress to use Group Forums.
    13. Please provide a list of any errors in your server’s log files.
    Not applicable.
    14. Which company provides your hosting?
    We self host.
    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Debian, Apache.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The ticket to which you refer will be part of our 1.6 release, which will be in beta soon.

    Avatar of thanoulai
    thanoulai
    Member

    @thanoulai

    Who can tell me how to troubleshoot where and how to hook the email checker to see on bp register page because I test the invalid email on buddypress register page it goes through the the step even though I have the si captcha recabtcha and wangguad on that page. any body can help or idea suggestion. Another problem is the bp register page title, description, and key word belong to the post title description and keyword. another problem is i cant post the new topic on my wpmu and bp site any idea here.
    I look forward to hearing from you.
    Levata

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.