Skip to:
Content
Pages
Categories
Search
Top
Bottom

The page you were looking for was not found.

  • Avatar of WillPCG
    Will White
    Participant

    @willpcg

    I’ve recently re-installed WMU 2.7.1 and got it working correctly. Then I downloaded the latest BP (1.0) and activated it. I then moved the bp-themes to the wp-content directory and bphome to the themes directory.

    I’ve activated the default theme and haven’t edited a single line of code yet.

    When I go to the site, I can get to places like Members, Group, Blogs etc – but when I load up a profile (with all the links to things like “The Wire” “Friends” etc) all the links load pages in the BP theme that say “Sorry, that page could not be found” and “The page you were looking for was not found.”

    Any thoughts on what could be causing this?

Viewing 14 replies - 26 through 39 (of 39 total)
  • Avatar of WillPCG
    Will White
    Participant

    @willpcg

    Thanks Jeff Sayre, I’ll contact them tonight.

    Avatar of Gladsteins
    gladsteins
    Participant

    @gladsteins

    “Let me ask all of you a question. On your root blog, the main blog of your site, what do you all have your WordPress MU Permalinks set to? Admin->Settings->Permalink”

    yes I have checked and the default themes that come with the download are installed

    bpskeletonmember and bpmemeber

    Avatar of Gladsteins
    gladsteins
    Participant

    @gladsteins

    permalinks are set to default http://smog.edmonds.wednet.edu/wordpress/?p=123

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    I just got off the phone with the folks hosting the server and they’ve corrected the incorrect session problem. Now visiting any of the buddypress pages don’t produce any error logs – but I’m still having the Page Not Found error on the activity, wire, friends, edit profile etc pages.

    Whats the next step?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    WillPCG-

    Okay,a few more questions, just to be thorough:

    1. Which version of PHP are you running?
    2. Have you made any changes to the .htaccess file?
    3. Did you even copy over the .htaccess file from the new WPMU package to your WPMU root?
    4. Questions about upgrading WPMU:

      • Where you running WPMU 2.7.1-beta1 before upgrading?
      • If so, how did you upgrade to the public version of WPMU 2.7.1?
      • Did you add the one additional define line to WPMU’s wp-config.php file? If not, compare the 2.7.1 config file to your old one. This line is new:

        define('SITE_ID_CURRENT_SITE', 1);

      • To complete your WPMU upgrade, did you go to “Site Admin > Upgrade” and finished the process?

    5. Are you running any plugins other than BuddyPress? If so, have you tried deactivating them?

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    1. Current Default version of PHP: 4. This is the default version of PHP that your site is currently using. Note that you can always choose between PHP4 and PHP5 for individual files by naming them with the corresponding extension. (Copied from IPower.com)

    2. Haven\’t made any changes to the default .htaccess file

    3. This might be the problem. I loaded the \”htaccess.dist\” with the files assuming it would put the .htaccess file. I\’ve tried three different buddypress installation ways – one through searching for the plugin inside wp-admin, one by installing the zip from here in the wp-admin, and one by ftp\’ing the contents of the zip. I would imagine one of them would have copied it over.

    4. I installed WPMU from scratch, including making a new mySQL database for it right before loading BP.

    5. No other plugins, pretty much running vanilla until I can get the pages I need working.

    What do you think?

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    Regarding #4 I just double checked, the define site id line *is* there, so it should be the correct version.

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    After trying everything I could via the host I was using at ipower.com – I decided to try loading the whole nine yards on another host to see if it would work. This time I tried hostmonster.com – still no success – which means it *has* to be something *I’m* doing wrong.

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    I’ve redownloaded everything back to the original server, and even made sure to upload (specifically) the bp-themes folder from here. After disabling bphome and just running on the classic wordpress theme whenever I visit any of the pages that involve BP scripts I get the error.

    You do not have any BuddyPress themes installed.

    Please move “/wp-content/plugins/buddypress/bp-themes/” to “/wp-content/bp-themes/” and refresh this page. You can download more themes here.

    The files are in the right place and when I go to BuddyPress settings as a site administrator both the bpmember and skeleton member themes are available. I’ve tried the click it method I’ve seen in other posts but its not working. Do you have another tactic at fixing that situation? I think that is whats causing the majority of these 404′s.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    After disabling bphome and just running on the classic wordpress theme whenever I visit any of the pages that involve BP scripts I get the error.

    A classic WordPress theme will not work with BuddyPress. There is BP-specific code within BP themes and BP theme folders. The question is, what happens when you use the standard BP themes that come with BuddyPress?

    Also, after switching to the standard BP themes, and if you’re still having issues, then you should set PHP to run on version 5 instead of 4 and see what happens.

    Avatar of Sueblimely
    Sueblimely
    Participant

    @sueblimely

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I think the next step is not installing WPMU/BP inside a directory called “members”

    The problem is that the members area hijacks the URL and looks for “members” in it; that’s how it knows to display the member area.

    I’m going to try this myself and see what happens, but I’m almost certain that is the issue here.

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    Hey Guys,

    Thanks for the help. I’ll be spending the rest of this morning following the potential fixes and let you know the outcome. Keep your fingers crossed!

    Avatar of WillPCG
    Will White
    Participant

    @willpcg

    Success at last!

    After uninstalling the whole shebang, dropping the database, and starting from scratch without using ‘members’ as a name for the files it all works now.

    Now its time to start customizing it – and hopefully not mess it up!

    Thanks again for all the help everyone!

Viewing 14 replies - 26 through 39 (of 39 total)

You must be logged in to reply to this topic.