Skip to:
Content
Pages
Categories
Search
Top
Bottom

The requested URL /register/ was not found on this server.

  • Avatar of Jonperry
    jonperry
    Participant

    @jonperry

    I just installed wordpress 2.9.2,

    I changed permalinks to: /index.php/%postname%/

    I installed the new buddypress 1.2

    I activated the plugin

    Activated the theme

    But now when I press any button like ‘Activity’ or ‘Members’ I get the following error:


    Not Found

    The requested URL /activity/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    WebServerX Server at featherme.com Port 80


    Anyone know what is happening?

    Thanks

    Jon

Viewing 25 replies - 1 through 25 (of 46 total)
  • Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    I’ve got exactly the same problem.

    Anyone’s got a solution for this one?

    Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    Wow. I digged this problem really hard but not successful so far.

    I know there are several topics regarding this issue but haven’t found definite solution.

    WP 2.9.2 + BP 1.2.

    WP works perfectly but every link connected with BP comes up with 404 error.

    I don’t use any other plug-in.

    Yes, I tried a fresh install, several times.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Did you update your .htaccess file when you updated the permalinks?

    Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    Maybe that’s the problem.

    I don’t have .htaccess file.

    What do I have to write on the file?

    Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    RewriteEngine On

    RewriteBase BASE/

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]

    RewriteRule . index.php [L]

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off

    </Files>

    </IfModule>

    Ok. I put this on .htaccess and it comes back with 500 internal server error.

    Now, not only buddypress but also WordPress does not work.

    The whole site is tangled with 500 error.

    If I delete .htaccess, WP works but BP comes with 404 error.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    Are you using single WP or WPMU? Because that’s the htaccess for MU. (yes, they are different)

    Avatar of bpinspire
    bpinspire
    Participant

    @bpinspire

    What should be the .htaccess for the single WP with BP?

    Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    Oops! I’m using a single WP.

    What’s the .htaccess for a single WP?

    Is it normal to get a 500 error with that .htaccess in a single WP?

    Avatar of trident46
    trident46
    Member

    @trident46

    Hello,

    I’m having the same issues……..I do not have an “.htaccess” file anywhere on my hosting server.

    I read that the two latest versions of WordPress and Buddypress may not be compatible – could this be the problem?

    Thank you!

    Rob

    Avatar of rogscorp
    rogscorp
    Participant

    @rogscorp

    Hey I solved this problem.

    There were two problems:

    1) no .htaccess

    2) Text editor in Mac

    You should have .htaccess in your FTP.

    Maybe it’s hidden, but if it is not, you should make one.

    You can make it with a simple text editor:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    copy and paste this and save it as .htaccess and upload it your root wp folder.

    Another problem for me was that I used the text editor in mac.

    Its RTF format put some information in the beginning of the file which is invisible in the text editor.

    That caused 500 error problem.

    So I made .htacess in Dreamweaver (the memo app in Windows would be OK I guess), and uploaded it, IT WORKED.

    I hope this would help for other people.

    The reason my FTP did not have .htacess in the first place is beyond me.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    sometimes when you copy items from a folder on harddrive to server via ftp program it misses hidden files like .htaccess

    You can create a file htaccess.txt add the rewrite code then upload it after upload change the name of the file to .htaccess

    I’m using WP single and this is whats in my .htacess file

    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    When you change your permalinks it shows you what you need to add to your .htaccess file at the bottom of the page.

    Avatar of trident46
    trident46
    Member

    @trident46

    I tried copying into all three folders – which one is it supposed to go in?

    At one point I couldn’t even access my WP admin dashboard……

    Avatar of consumers
    consumers
    Member

    @consumers

    I’m having the same issue. try all of the above and when clicking on the activitity, members, groups links I’m getting a 404 error.

    Avatar of trident46
    trident46
    Member

    @trident46

    I know the feeling :)

    I’ve tried copying the what Modemlooper posted, as well as the smaller code that displays on the permalinks page…I’ve put both, separately, in all three folders, one at a time, and nothing works.

    Frustrating ….lol

    Avatar of consumers
    consumers
    Member

    @consumers

    is there any solution to this?

    Avatar of Meerblickzimmer
    Meerblickzimmer
    Participant

    @meerblickzimmer

    Jepp. Same problem and no solution. Tried a lot of thinks and nothing works. :-(

    Avatar of Meerblickzimmer
    Meerblickzimmer
    Participant

    @meerblickzimmer

    I tryed a ticket but its cloesd now (http://trac.buddypress.org/ticket/2246) Any solution for this problem. Looks like i´m not allone with this bug. If i deactivate the buddypress-default theme, it works fine, registration is possible. But not with the buddypress-theme.

    Any solutions out there?

    Thanks a lot!

    M

    Avatar of Tom Gosling
    Tom Gosling
    Participant

    @tomgosling

    I’m 99.9 percent sure that you guys need to enable mod_rewrite in Apache…

    Avatar of Jason Peters
    Jason Peters
    Participant

    @zee1652

    hey everyone. Think I got the same prob… If you could check it out?
    http://zeandre-co-za.win33.glodns.net/
    Thanks

    Has anyone made any progress on this one? I’ve a XAMPP setup running on XP Service Pack 3 behind a corporate firewall. WordPress seems to work fine – I can configure, add BuddyPress, activate plug in and themes, etc. I have a .htaccess sitting in C:xampphtdocswordpress-mu which looks like the htaccess.dist file but with modifications.

    Clicking on http://computername.corporatedomainname.com/wordpress-mu/ (where I am installed) lets me go to the BuddyPress home page (and very exciting it is too). Then clicking on the “Members” tab give me a http://computername.corporeatedomainname.com/wordpress-mu/members/ and

    “Object not found!

    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.
    Error 404″

    Avatar of Rooster
    Rooster
    Participant

    @exitrooster

    Okay.. I tried modemlooper’s sample, (I have the regular/single wp install) and this is what happens..

    my site, for example is http://www.widget.com/familyblog/
    It comes up fine. But when I click on any of the BP content buttons (you know the drill, all the ones people above are talking about), it redirects me to pages missing the 1st letter of my website, eg:
    http://www.idget.com/familyblog/members/

    I’ve copy/pasted it several times, every time results in the same response. What can/should I do?

    Is there any way to use BP without having to jump through all these hoops dealing/fighting with .htaccess? You know, like the regular WP works flawlessly without such nonsense :(

    Has anyone solved this yet? I am still getting this error.

    I can configure, add BuddyPress, activate plug in and themes, etc.

    Clicking on http://computername.corporatedomainname.com/wordpress-mu/ (where I am installed) lets me go to the BuddyPress home page (and very exciting it is too). Then clicking on the “Members” tab give me a http://computername.corporeatedomainname.com/wordpress-mu/members/ and

    “Object not found!

    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.
    Error 404?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Part of the problem might be running BuddyPress in a subdirectory. We use some tricky URI parsing to dynamically trap and trigger the pages that don’t actually exist. To do this, we count the slashes and put the slugs in the “correct” positions, which in your case are one level off.

    You could .htaccess your way out of this by redirecting, but your best bet is to install it at the root of your site.

    For those only having the trouble with /register and /activate, make sure you have member registration turned on. Since it’s off by default on single site WordPress, that has gotten me a few times.

    Thank you John for replying to my post. Do you think I have to reinstall everything to put Buddy Press and MU on sub domains? I chose sub directory because I didn’t know anything about wildcard DNS.

    Could you tell me more by what you mean my correct positions are one level off or is there a .htaccess that can fix it so I don’t have to reinstall? here is what my .htaccess shows.

    RewriteEngine On
    RewriteBase /Case_study/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    SecFilterEngine Off
    SecFilterScanPOST Off

Viewing 25 replies - 1 through 25 (of 46 total)

You must be logged in to reply to this topic.