Skip to:
Content
Pages
Categories
Search
Top
Bottom

Theme My Login plugin & Buddypress

  • Avatar of jessicana
    jessicana
    Participant

    @jessicana

    Hello,

    I am using Theme My Login (tml) to manage my site users, I use WP+ Buddypress + BBpress.

    I am using Buddypress, if you go from the wordpress admin panel to settings > Buddypress > Pages.

    Under [Registration], buddypress asks the users to associate WordPress Pages with the following BuddyPress Registration pages:
    1) Register.
    2) Activate.

    I also receive this message in my WP admin panel: The following active BuddyPress Components do not have associated WordPress Pages: Activate, Register. {Repair}

    If I try to link the Buddypress register page to the current TML registration page, I get a white page the my panel stops. Please advice how to link those buddypress pages with TML pages.

    What do you suggest I do?

    Regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of sharmavishal
    sharmavishal
    Participant

    @sharmavishal

    keep only one register page…delete the register1 or register2 page and in the register main page add this [theme-my-login] in the content and save it and in buddypress settings put this correct register page in the pages section

    Avatar of jessicana
    jessicana
    Participant

    @jessicana

    Well, I did that and I have buddypress default registration page. The default registration page has the name as a required field and it can be seen by everyone, I am having problem with buddypress default registration page for many reasons:
    1) If you visit the default buddypress registration page, and leave all the fields blanks and hit complete sign up, you will only receive three red notifications for required accounts details as follows:
    a. Please enter a username
    b. Please check your email address.
    c. Please make sure you enter your password twice
    Although the name is a required field, but you don’t receive similar message for a required field, and if the user don’t fill the name, the page refreshes without asking the user to fill the name.

    2) Having the name as a required feild, will discourage users registration and I am not sure how to make it optional at the registration stage.

    Thank you

    Avatar of sharmavishal
    sharmavishal
    Participant

    @sharmavishal

    i guess somethings wrong with your install. do a fresh install…install latest versions of BP and TML and then check again….regarding your points

    1. name is a required field and i do get the Name (required) This is a required field if the user doesnt put in this name. so it works for me.

    2. name is required for bp. profiles wont work correctly as that name field is used in user profiles and member directory

    Avatar of jeffsun22
    jeffsun22
    Participant

    @jeffsun22

    I am not sure its an install issue. I had the exact same problem. I got rid of my issue by turning off a couple of the buddypress ‘components’ under settings. this made everything work again…. s

    Avatar of jessicana
    jessicana
    Participant

    @jessicana

    @jeffsun22

    What components you turned off under settings?

    Avatar of jeffsun22
    jeffsun22
    Participant

    @jeffsun22

    I turned off almost all of them and looked at the page settings they reset back to default. Then I turned them back on. Everything seems to work again.

    Avatar of jessicana
    jessicana
    Participant

    @jessicana

    @jeffsun22

    I tried this option and it didn’t work for me.

    There are 8 components that I turned off then I saved the settings. After that I turned them on and I received the same result.

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.