Skip to:
Content
Pages
Categories
Search
Top
Bottom

"There was a problem posting your update, please try again."

  • Avatar of zooney
    Zooney
    Participant

    @zooney

    Hrrm, is anyone else getting:

    “There was a problem posting your update, please try again.” in a red box every time they try to post any sort of update in BuddyPress 1.2?

    I’m running:

    Wordpress 2.9.1

    BuddyPress 1.2

    …I’m not even sure where to begin troubleshooting.

Viewing 25 replies - 1 through 25 (of 28 total)
  • Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    My problem exactly, however today is the first time I have actually done something that displayed this error.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Why is this HAPPENING!?!?!?!? I am running on Win2k8 w/ IIS7 and FastCGI installed. I really want to get this resolved! Is this the location to post a support request? Is this a bug? What? Help please.

    Avatar of Michaelmarian
    michaelmarian
    Participant

    @michaelmarian

    I just discovered this as well. Windows 2003 server. Buddypress 1.2 WordPress 2.9.1

    Avatar of bpinspire
    bpinspire
    Participant

    @bpinspire

    I have the same issue BP1.2 WordPres 2.9.2

    Avatar of zooney
    Zooney
    Participant

    @zooney

    Hrrm… I’ve found this old ticket:

    http://trac.buddypress.org/ticket/1647

    …and the advice is to “upgrade your db” whatever that vague phrase is meant to mean. I installed a fresh copy of both WordPress Mu and BuddyPress from the ground up and still get the issue.

    I opened my own ticket a few days ago:

    http://trac.buddypress.org/ticket/1999

    …if anyone has anything to add to it. I just can’t even begin to trace what the problem is.

    did you try a fresh database as well?

    i remember an issue while testing the trunk awhile back – turned out to be a change in the date format. You may have to dig deeper and see what information is being passed to bp_activity_add (or at least echo it out)

    Avatar of zooney
    Zooney
    Participant

    @zooney

    I’ve started with a fresh install of WordPress Mu (new database and all) and still get this issue.

    Thanks for the tip about bp_activity_add. I’ll start looking there.

    Avatar of zooney
    Zooney
    Participant

    @zooney

    I’m also getting a lot of:

    “Sorry, there was no activity found. Please try a different filter.”

    …messages in orange boxes. Although I’m sure it should be listing some activity…

    Avatar of zooney
    Zooney
    Participant

    @zooney

    …ah-ha…

    This is being caused by MySQL running in strict mode… …shutting off strict mode stops the issue (could be a temporary work-around for some people).

    …does BuddyPress support strict mode?

    If anything, there must be some bug in there which is trying to add improperly formatted data to the database…

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    How do you turn off strict mode?

    Avatar of zooney
    Zooney
    Participant

    @zooney

    To turn of strict mode in MySQL you’ll have to locate your MySQL instance’s .ini file and look for a line like:

    sql-mode=STRICT_TRANS_TABLES,…

    And remove “STRICT_TRANS_TABLES” and restart the instance.

    Unfortunately the scope of this setting is for the entire MySQL server instance and can’t be done on a schema-by-schema basis…

    I’d only do this as a workaround, though. My guess is that BuddyPress should be supporting strict mode, and there’s just a bug in there…

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Ok, thank you. Yes, turning that off worked fine. Now, has the bug been reported?

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Nevermind, I see that zooney took care of us 5 days ago. I guess (s)he said that in a previous post. Thank you.

    Avatar of zooney
    Zooney
    Participant

    @zooney

    I’ve reported it in this ticket:

    http://trac.buddypress.org/ticket/1999

    I’ve made a few updates to the ticket after I figured out it was being caused by strict mode… …hopefully someone closer to BuddyPress can sort this out, but I s’pose I’ll keep digging through the code to see if I can find the actual bug…

    Avatar of Michaelmarian
    michaelmarian
    Participant

    @michaelmarian

    Zooney,

    commenting out this

    # sql-mode=STRICT_TRANS_TABLES,…

    in my.ini on windows did the trick. I’m just wondering though if this will have any negative side effects. So I’m looking forward to the result of your ticket 1999

    Avatar of zooney
    Zooney
    Participant

    @zooney

    Hrrm, I’ve been updating the ticket (first of all to add the milestone of 1.2.2)… d’oh…

    I’ve looked at my error logs and have come up with an error like this:

    WordPress database error Field 'mptt_left' doesn't have a default value for query INSERT INTO wp_bp_activity ( user_id, component, type, action, content, primary_link, date_recorded, item_id, secondary_item_id, hide_sitewide ) VALUES ( 1, 'activity', 'activity_update', '<a href=\"http://localhost.localdomain/BuddyPress/members/admin/\" title=\"admin\">admin</a> posted an update:', 'Update.', 'http://localhost.localdomain/BuddyPress/members/admin/', '2010-02-24 14:23:43', '', '', 0 ) made by require_once, require_once, do_action, call_user_func_array, bp_core_add_ajax_hook, do_action, call_user_func_array, bp_dtheme_post_update, bp_activity_post_update, bp_activity_add, BP_Activity_Activity->save

    So, either something is going wrong by the time BP_Activity_Activity->save is being called…

    …or, the wp_bp_activity table simply needs a default value for mptt_left when the table is created in the first place.

    If you don’t mind messing with your database tables, I’ve found that simply adding a default value of 0 for the mptt_left and mptt_right columns corrects the error as well, without the need to turn off strict mode.

    It’s hard to see if this bug is an improperly defined table, or an improperly formed function call…

    …anyone have any thoughts?

    Avatar of sporty
    sporty
    Participant

    @sporty

    Same problem. I know knowing about PHP or mysql – is there someone I can pay, or chip in to pay to solve this? The whole website is useless without it so happy to make a donation to get over this frustration.

    Couldn’t find a *.ini file anywhere so not sure how to impliment Michaelmarian’s idea

    Couldn’t even find a relevant error log file of any kind on the server, certainly nothing in the inetpub directory

    if I follow the idea of turning off the STRICT, is my, MySQL instance the one in C:\Program Files\MySQL\MySQL Server 5.1\my.ini ? can anyone advise what other impact there might be?

    cheers

    ewart

    Avatar of sporty
    sporty
    Participant

    @sporty

    I took a punt and removed STRICT from the my.ini inside c:\programfiles\mysql\mysql… and posting now works but still unsure about the impact of this change?

    Avatar of zooney
    Zooney
    Participant

    @zooney

    …err, I think the change would probably only be horribly detrimental if you were running anything else out of that database that required strict transactions.

    It’s likely that there won’t be much impact, but there’s really no way for me to say.

    Alternatively, you could just modify the table in the database to give those two values a default… That’s a little involved. You’ll need to make some queries and have the ALTER_TABLES privilege and all of that…

    A kind soul added to the ticket I posted (#1999) and found where the table in question was actually being defined and added defaults to the columns that seem to be causing the issue.

    Hopefully that will provide a fix, but I don’t know enough about BuddyPress to even know what those columns do…

    Avatar of zooney
    Zooney
    Participant

    @zooney

    Looks like we’ve got a fix for this:

    http://trac.buddypress.org/ticket/1999

    The milestone seems to be for 1.2.3, but that patch should work for now.

    Avatar of mollyfud
    mollyfud
    Participant

    @mollyfud

    I am having this issue still. I have a 2.9.2 Standalone WordPress with Latest Buddypress pluggin. I have created the BBpress install with the built in one click install. I can’t see anything extra that I need to do to set it up, is there anything?

    I looked and the table seems to have the fix described in the ticket 1999. Has anyone seen anything like this? Have I done something wrong?

    TIA

    Avatar of zooney
    Zooney
    Participant

    @zooney

    Hrrm… I’m no longer getting the issue after the fix…

    Have you checked your error logs to see if something strange is going on?

    Avatar of mollyfud
    mollyfud
    Participant

    @mollyfud

    Thanks Zooney. I checked it out and there are lots of PDO related errors. I am on a hosted system (Bluehost.com to be exact). Could these PDO errors be the issue?

    Avatar of mollyfud
    mollyfud
    Participant

    @mollyfud

    just doing a phpinfo, it seems that there are PDO packages (see http://aflspace.com/phpinfo.php)

    Avatar of zooney
    Zooney
    Participant

    @zooney

    Hrrm, what do these PDO errors say?

    PDO is essentially a library of database drivers. These errors would probably have something to do with things not being properly written to your database…

    It may be a different issue entirely, it’s hard to say.

Viewing 25 replies - 1 through 25 (of 28 total)

You must be logged in to reply to this topic.