Skip to:
Content
Pages
Categories
Search
Top
Bottom

To be compatible with WP 3.1 and BP 1.2.8

  • Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    1) Make sure that the plugin is activated as network.
    2) Change as followings:
    At line 36 of upm.php:
    `
    [ Original ]
    add_action( ‘admin_menu’, ‘upm_setup_globals’, 2 );
    [ Changed to ]
    add_action( ‘network_admin_menu’, ‘upm_setup_globals’, 2 );
    `
    At line 58 of upm.php:
    `
    [ Original ]
    add_action( ‘admin_menu’, ‘bp_upm_menu’ );
    [ Changed to ]
    add_action( ‘network_admin_menu’, ‘bp_upm_menu’ );
    `

    At line 63 of /admin/upm-admin.php:
    `
    [ Original ]
    a href=”/wp-admin/admin.php?page=bp-profile-setup
    [ Changed to ]
    a href=”/wp-admin/network/admin.php?page=bp-profile-setup
    `

    At line 65 of /admin/upm-admin.php:
    `
    [ Original ]
    site_url() . ‘/wp-admin/admin.php?page=bp-upm-settings’
    [ Changed to ]
    site_url() . ‘/wp-admin/network/admin.php?page=bp-upm-settings’
    `

    I hope this will work.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.