Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unable to activate the 4sq on WP 3.0

  • Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    When I upload it and try to enable it I get this error msg:
    Plugin could not be activated because it triggered a fatal error.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    FYI

    error: Warning: require_once(./bp-foursquare-classes) [function.require-once]: failed to open stream:

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    I would be nice to get foursquare plugin to work like this demo site on BP

    http://www.vrwebdesign.co.uk/virtual-tours/google-maps/

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    @Gpo1 it’s just a simple path error, open bp-foursquare.php and change:
    require_once ( ‘./bp-foursquare-classes’ );
    To:

    require_once ( ‘bp-foursquare-classes’ );

    When you have it running give us all a brief ‘How To’ as it’s not apparent how to use or why, not really familiar with this App.

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    @hnla Still failed after require_once ( ‘bp-foursquare-classes’ ); change

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Should be fine, did you reactivate the plugin? rather than just refresh the page? All (2) files are in the same top level folder?

    try adding the file extension on ‘bp-foursquare-classes.php’

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    I did but no joy,Have you tried it?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Well plugin activates fine but I have no idea how or what to use it for :)

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    I’m using local host and wp3.0 and latest BP

    Avatar of christianebuddy
    Vakantie Ameland
    Member

    @christianebuddy

    Maybe it’s better to use this code:

    require_once( WP_PLUGIN_DIR . ‘/bp-foursquare-api/bp-foursquare-classes.php’ );

    Avatar of TM
    TM
    Participant

    @tiagom

    Tried it, get a syntax error and then a directory error. Has anybody gotten the plug-in to work? I’m trying to include it on a page template to test it out and style the UI, but so far no luck.

    Avatar of TM
    TM
    Participant

    @tiagom

    k, it might’ve been a path error. Got the messages to go away follow christianbuddy’s suggestion, tweaking it for my own path: . I’m still not sure what’s supposed to come out of it. An OAuth dialog? Raw XML? Can the developer please explain?

    i dont understand hoy to use…

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.