Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unable To Upload Avatars

  • Avatar of preacherboy86
    preacherboy86
    Member

    @preacherboy86

    Hey everyone,

    I’ve set up a WordPress multisite installation using the latest version of WordPress (3.0.1) and the latest version of BuddyPress (1.2.6). I made my one subsite the root blog for BuddyPress, as I want my main site to be informational while this subsite to serve as my main site’s social network.

    When I try to upload an avatar for my profile, I receive the following error:
    “Upload Failed! Error was: Unable to create directory /avatars/1. Is its parent directory writable by the server?”

    I receive a similar error when trying to upload an avatar for a group:
    Upload Failed! Error was: Unable to create directory /group-avatars/1. Is its parent directory writable by the server?

    My “wp-content” folder has 755 permissions, so I’m unsure of the issue. I’ve looked through forums here and on WordPress for the last couple of days. While there have been forums on this topic, none have necessarily had my particular conditions (wordpress 3.0 multisite with the buddypress root in a subsite.)

    Any and all help so I can simply upload an avatar to either a profile or a group would be greatly appreciated. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of techguy
    techguy
    Participant

    @crashutah

    Definitely looks like a permission issue to me. I’d check the file permissions on the sub folders to make sure that the permission is cascading down the way it should. Depending on your web server setup, I think that the user and group that owns the folder could be an issue.

    Avatar of preacherboy86
    preacherboy86
    Member

    @preacherboy86

    I’ had temporarily set the wp-content directory and blogs.dir to 777 permissions and tried to upload avatars – still didn’t work. I’ve checked with my webhost (site5), they did the same thing and it didn’t work either.

    Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    I’ve seen this error before and cleared it up by removing the /uploads directory and recreating it. Set permissions to 755 (owner should be correct too). Next go to /wp-admin/options-media.php and make sure you leave this as default /wp-content/uploads (leave it blank)… tick the `Organize my uploads into month- and year-based folders` and save.

    This fixed it for me. Hopefully it helps you too.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    This is nearly always a owner/group issue and these need to be set correctly from the server – also and importantly make sure PHP Safe Mode is not enabled which I’ve mentioned in a few threads here.

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Yes, I’ll second @hnla.. Definitely watch for safe mode! And backing up on checking owner – group settings, thats the reason deleting the autocreated uploads folder works.. When you recreate manually it changes the owner

    Avatar of preacherboy86
    preacherboy86
    Member

    @preacherboy86

    Thanks for the idea @LPH2005 – but I’m using multisite, so I don’t have the “Uploading Files” section on my media options page. Not sure why that is, but it is.

    I’ve asked the good folks at site5 (my webhost) to check out the issues @hnla referred to.

    Avatar of preacherboy86
    preacherboy86
    Member

    @preacherboy86

    Looks like my webhost managed to fix the upload issue. As you might expect, I made a rather dumb mistake. Although I’m not too technical, so no surprises!

    “The problem was the blogs.dir directory was created as a file rather than a directory”

    Although NOW my issue is that once the image is uploaded, the jquery cropper fails to load, so I’m still unable to get unique images to either profiles or groups. I know many others are having this particular problem, too. If others have particular insights into fixing the jcropper issue – please post. Thanks!!

    And again, I’m using WordPress (3.0.1) in multisite and the latest version of BuddyPress (1.2.6) on a subsite.

    Avatar of preacherboy86
    preacherboy86
    Member

    @preacherboy86

    And I fixed my jcropper issue, too. I really don’t know how I managed to do this, but there was an extra “s” in ms-files.php in my .htaccess file.

    Originally, it was:
    # uploaded files
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-filess.php?file=$2 [L]

    Should have been (and I changed it to):
    # uploaded files
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

    Avatar of techguy
    techguy
    Participant

    @crashutah

    Glad to hear it’s working and thanks for sharing the solution for others that might have a similar problem.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.