Skip to:
Content
Pages
Categories
Search
Top
Bottom

Undefined Function Error

  • Avatar of tombwriter
    tombwriter
    Participant

    @tombwriter

    I have been having difficulty with my BuddyPress forum. After successfully updating to the latest version, and adding some new topics and groups, a couple of weeks later I received the following error:

    Fatal error: Call to undefined function groups_total_forum_topic_count() in /home/…/wp-content/plugins/buddypress/bp-forums/bp-forums-template.php on line 156

    I’ve tried to find the solution on various forums, and aside from reinstalling BuddyPress 1.6.1, which did not help, nothing has helped. Is there a fix?

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    What theme are you using? Have you checked if same error shows up if you change to bp-default theme? What plugins are installed?

    Avatar of tombwriter
    tombwriter
    Participant

    @tombwriter

    Mercime

    I am using the buddypress 1.6.1 default theme. The activated plugins are bbpress and buddypress. There are other deactivated plugins. Does that help?

    Thanks.

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    If you’re using bbPress 2; as part of using that, did you disable the so-called “Group forums” component in BuddyPress?

    Avatar of tombwriter
    tombwriter
    Participant

    @tombwriter

    Paul,

    I could not find the Group Forums component. When I logged in, I saw that there was an update for Buddypress, so I updated, figuring that might help. Instead, it gave me a similar Function error (Fatal error: Call to undefined function wp_get_theme() in /home/fullcirc/public_html/directaccess.us/wp-content/plugins/buddypress/bp-core/admin/bp-core-functions.php on line 242) when I tried to access the Dashboard. Now I have two problems! :(

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Ah hah. If you are getting warnings about “wp_get_theme”, you mustn’t be on WordPress 3.4+. You’ll need to downgrade BuddyPress, or upgrade WordPress (preferably the latter).
    See this table for version requirements http://codex.buddypress.org/releases/

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.