Skip to:
Content
Pages
Categories
Search
Top
Bottom

upgrade to Wp 3 from Wp 2.9.2 with buddy press

  • Avatar of gwu123
    gwu123
    Participant

    @gwu123

    I want to know what will be the challenges is upgrading from WP2.9.2 to WP3 with respect to Buddypress 1.2.4.1.

    In other words I have Buddypress 1.2.4.1 working fine on WP 2.9.2, now I want to upgrade to WP 3, what can be the issues that I will face.

    Thanks,

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    You shouldn’t have any. I’d recommended backing everything up, switching back to the default WordPress theme and disabling all plugins (including BuddyPress). Then when you have WP 3.0 up and working, re-enable everything one-by-one.

    Avatar of LwEEs
    LwEEs
    Participant

    @menel001

    I can’t set up the Activity Stream in my home page, did you know about that? Do you know of a fix?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    This has been raised on another thread and I made comment at my surprise that so many appear to be rushing into upgrades to WP 3.0 which isn’t at stable final release yet (although rc 1 is likely the stable version ) in tandem with 1.2.4.1. There seems a belief that 1.2.4.1 is tested and intended to work with WP 3.0 yet reading the roadmaps and the only mention you will see of WP 3.0 is in the notes for BP 1.3, BP 1.2.4 makes no mention of WP 3.0.

    Unless others know to the contrary 1.3 is the version that will be written to work fully with WP 3.0, that 1.2.4 does work is a testament to the fact that BP is getting to a stage where it will work pretty smoothly with any releases, but WP3.0 is a major version release with fundamental changes.

    Avatar of LwEEs
    LwEEs
    Participant

    @menel001

    Thanks hnla, I’ll look forward the next release or a patch whatever comes first.

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    1.2.4.1 should work fine with WP 3.0. BP 1.3 will *require* WP 3.0 and some of the internals will be changing for compatibilty with WP 3.0.

    Avatar of gwu123
    gwu123
    Participant

    @gwu123

    Thanks @Paul

    I have been developing a website based on WP 2.9.2 and BP 2.4, which make take 1-2 months before launch. So, I just wanted to know if by the time of dev complete or launch a new version of BP and WP comes out how easily can I handle it. Or would it be worth to wait for WP 3 and BP 1.3 and then do the launch. I am not in hurry, and I do not want to put time in migrating from one version to other since I am goin to have a lot of custom code.

    Thanks

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    1.2.4.1 should work fine with WP 3.0.

    That appears to be a case of yes and no though Paul, indeed it does “”appear” to work fine and I have a 1.2.4.1 running on WP 3.0 RC1 that is by and large OK yet it does have this issue with activity stream working on the front page so should work fine doesn’t sadly hold up. Again I wouldn’t be rushing to run 1.2.4.1 on WP 3.0 in a production environment rather waiting for BP 1.3 to be released and then a while for it’s issues to be ironed out.

    Avatar of Arun Basil Lal
    Arun Basil Lal
    Member

    @arunbasillal

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.