Skip to:
Content
Pages
Categories
Search
Top
Bottom

upload problem

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of foxly
    foxly
    Participant

    @foxly

    Could you be a little more specific?

    What version of BP Album+?
    What is the “Upload Thing” doing?

    ^F^

    Hi there, I’m having problems uploading files too. The problem is related to the BP_ALBUM_UPLOAD_PATH constant contruction. The files are uploaded to a wrong directory. This is a example where the files are being uploaded:
    http://localhost/lovingfutbolC:wwwappslovingfutbol/wp-content/uploads/album/1/logo_artvisual-150×150.gif .
    I dont know why this is happening.
    Wordpress 3.0 Multisite + Buddypress Latest Brach 1.2 + BP Album 0.17

    Avatar of foxly
    foxly
    Participant

    @foxly

    The reason is probably because you’re using buggy pre-release versions of WordPress and Buddypress on an incorrectly configured home PC.

    1) To start with, you’re testing with a version of WordPress that, according to wordpress.org “…has over 200 bugs that we are still working on” (as of 5 days ago). So before I can provide you with *any* help, you’re going to have to uninstall wordpress and install the 2.9.2 RELEASE version.

    2) If you’re using a branch version of Buddypress from the repo, it likely has dozens of bugs as well. So you’ll need to switch to the latest RELEASE version.

    3) The example upload location you posted cannot exist on either a Windows or Linux filesystem because it has a “:” character in it. Even then, it would not have been generated by BP Album+ because the plugin uses JPG files for thumbnails.

    4) If the URL you posted above is at least *partly* correct, and you’re using a multi-site (wpmu) version of wordpress, you will have incessant, frustrating problems until you edit your hosts file and assign a fake domain name to your computer.

    After you’ve got all your computer issues sorted out, please post a step-by-step list of the what’s happening and how to reproduce the problem.

    We’ll be happy to help you out… :)

    ^F^

    Hi @foxly, thank you so much for your answer.
    I´ve tested on WP MU 2.9.2 and is working fine!
    I supose that as you say in point 4) WP3 is not creating URL properly. But it’s strange that other plugins as Buddypress and BuddyPress Classifieds aren’t having these uploading problems.
    Thank you very much for all

    Avatar of foxly
    foxly
    Participant

    @foxly

    It’s probably because there are a huge number of different ways that plugins handle “uploading” in WordPress.

    Most plugins just have to handle generating an avatar image of some sort, which is built-in to WordPress anyway. We’re on the bleeding edge of it, having to handle many different image formats, plus audio, video, and embedded content. We have to rip intermediate versions of images so they download quickly on mobile phones but still look good on high def monitors, and cache them so they can be accessed quickly. And we have to do it on a massive scale – with tens of millions of images and terabytes of data.

    So yes… a bit different from other plugins.

    Wait until we get 0.1.9 out in a few days …you’ll see what we’ve been up to.. :)

    ^F^

    Avatar of stormin303
    stormin303
    Participant

    @stormin303

    Sounds similar to what I’m getting but I’m using official releases – WPMU 2.9.2 BP 1.2.3 and Album 0.1.7

    My image locations end up looking like like this with BP Album on a Linux server running Nginx proxying to Apache2.

    http://mysite.com/var/www/mysite.com/public/wp-content/blogs.dir/1/files/album/1/dp.jpg

    I’ve messed around with the rewrites but whenever I get BP Album to work it breaks all image links in BuddyPress and beyond.

    I got it working on an older version some months ago on a development server which is no longer in existence and if I remember correctly that was by hacking the Album code itself but for the life of me can’t remember what I did.

    Will wait til 0.1.9 comes out to see if that fixes the issue, if not I guess I can try hacking the new version again. Just strange how this is the only plugin that I have issues with so i can;t see how it can be my setup because everything else just works nice and dandy :)

    Avatar of foxly
    foxly
    Participant

    @foxly

    It’s probably because, on a programming level, when BP Album+ says “tell me the filepath to your storage directory” the server says one thing, and then when BP Album+ tries to actually send the web browser to that URL, the server says “just kidding”. In fact, looking at the URL you posted, I can see that’s exactly what happened. A: [http://mysite.com/var/www/] B:[mysite.com/public/wp-content/blogs.dir/1/files/album/1/dp.jpg] where “A” is the part your redirect is adding to the URL, and B is the actual correct URL.

    The upcoming version of BP Album+ will probably solve your problem.

    Version 0.1.9 lets you configure absolutely, positively, every filepath and directory offset to generate valid URLs no matter how badly your server’s screwed up.

    Need to run BP Album+ on your refrigerator’s web server while storing images to the shared network drive on your neighbor’s unsecured wi-fi connection?

    No problem.

    Need to run BP Album+ on an obscure Russian proxy server that’s only been around since December 2009. We can probably make that work too … :)

    It’s interesting that out of like … 7,000 users… you guys are the only ones reporting this problem. We need to figure out what’s unique about your servers…

    ^F^

    Avatar of stormin303
    stormin303
    Participant

    @stormin303

    Tried it without Nginx and used Apache2 instead and the problem still persists.

    Any chance you can post a valid htaccess file so that we can compare and contrast just in case?

    Avatar of foxly
    foxly
    Participant

    @foxly

    RewriteEngine On
    RewriteBase BASE/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    SecFilterEngine Off
    SecFilterScanPOST Off

    Avatar of foxly
    foxly
    Participant

    @foxly

    Avatar of Ekine
    Ekine
    Participant

    @ekine

    I had the same problem. Enabling mod_rewrite should help. When using an osx x server you should edit: etc/apache2/httpd.conf


    #AllowOverride controls what directives may be placed in .htaccess files.
    #It can be “All”, “None”, or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    AllowOverride All

    & also edit: etc/apache2/users/username.conf

    Options Indexes FollowSymLinks MultiViews
    AllowOverride All AuthConfig
    Order allow,deny
    Allow from all

    Avatar of heliocorreia
    heliocorreia
    Member

    @heliocorreia

    @arques,

    I’d made one single fix on .htaccess:

    #uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    #RewriteRule ^(.*/)?files/$ index.php [L]
    #RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    #RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.