Skip to:
Content
Pages
Categories
Search
Top
Bottom

Urgent: Usernames with dashes not working properly

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    Hi Greg,
    Put this in bp-custom.php
    `
    define(‘BP_ENABLE_USERNAME_COMPATIBILITY_MODE’,true);
    `
    this should allow you to see their profile.

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    Thanks Brajesh. Added the line, no luck.

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    Hi Greg, which version of wp/bp you are using. Also, is it multisite install(I guess, It is). Have you used anything to enable spaces in username, because wpms/bp does not allow spaces in name by default?

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    wp 3.1.4 and bp 1.2.8, yes, ms.

    No, nothing to enable spaces. That’s the weird part. we’ve never had a space/dash signup before.

    There are a bunch of issues in BP 1.2.9 to do with spaces in user names and other weirdness (for example, in @mentions). BP_ENABLE_USERNAME_COMPATIBILITY_MODE basically tells BP to look up the user name in the URL against the wp_user table’s user_login column. By default, it uses the user_nicename column.

    I think the answer might be to change this user’s nicename. What does it look like in the database?

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    deleted.

    I’m signing them up again…

    You think fixed in 1.2.9?

    No, but (afaik) definitely on 1.3. Try to break it on testbp.org if you get bored!

    Avatar of sasanchez
    sasanchez
    Member

    @sasanchez

    I have the opposite problem. I’m starting a site where users will sign up with first and last name as their username with a space between the first and last.

    What do I need to change so the site won’t convert an entered username of ‘Steven Sanchez’ to ‘Steven-Sanchez’? I’d like the site to accept usernames with a space.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.