Skip to:
Content
Pages
Categories
Search
Top
Bottom

v 0.1.8 – Deleting any user causes all bp-album activity to disappear from the activity stream

  • Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Deleting any user from our BP install causes all bp-album activity (for all users) to disappear from the activity stream.

    The photos remain in a user’s profile, but have had their visibility changed to private and comments have been made closed.

    I’ve noticed this problem reported elsewhere, but without any solution (other than de-activating bp-album prior to deleting users). Is there a fix?

    We are on v 0.1.8, BP 1.2.6, WP 3.0.1

Viewing 21 replies - 1 through 21 (of 21 total)
  • Avatar of foxly
    foxly
    Participant

    @foxly

    @rogercoathup

    Wow… that sounds like an “epic fail” on our part.

    First for not catching it, and second for not fixing it after (presumably) somebody reported it …although it is not in the bug tracker.

    If this defect is causing your clients major stress, I can try and put together a hack for you; however, if you’ve made it this far, you might want to consider just waiting until we release 0.1.9. It has a far more advanced data model, and is more-or-less free of these kinds of problems.

    ^F^

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @foxly -

    If you can release a fix (hack) for 0.1.8 that would be excellent.

    My understanding is that v0.1.9 will require us to re-work a lot more templates to match the look, feel and layout of our sites. We are likely, therefore, to keep some of our sites on v0.1.8

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    thanks for posting about what was going on, Roger. :)
    I can definitely confirm that deleting members from my site makes all images “private” which were once public. In order to delete spammers, I need to first deactivate BP Album and reactivate it after I’m finished deleting. Marking a member as “spam” works fine and causes no malfunctions to BP Album. It’s just when I delete. @foxly BP Album is really great. I hope there’s an easy hack to fix this issue. Though, I’m scared to try it on my site for fear I’ll have to manually make public images by hand again. I guess I can backup first. Hope that will work.

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @foxly hi. it seems that it randomly decides to turn public pictures private and disable commentary by clicking on “mark user as spam” also if BP Albums are not disabled first also. It doesn’t turn all of them private, just a few here and there. I am currently going through the thousands of images on my site remarking public images that were turned private back to public. I hope that a fix is in the works for the plug in as it’s very hard to delete spammers or mark users as spammers without creating a pile of work if I do so. :( Do you have any suggestions in the mean time?

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    Deleting sites also causes images to all turn private without deactivating BP Album first. I unfortunately just found that out. A hack would be most appreciated. Going to spend another long night reactivating images manually again. :(

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    After spending the better part of my entire day yesterday and my entire night and into the morning turning images back to public after the glitches in this plug-in have started taking over my life. Today I installed a new plug-in. A very harmless action. Just installing. Not even activating it yet. And… You guessed it! All images on the site were made private once again. I would like to invite someone else to come to my website and reactivate all the images. Because this is turning me into a crazy woman. And ZERO help or response from the developer on this. It makes me less likely to donate. Heck… I would pay to have this fixed so I can get my life back. I have sent private emails, made a bug report, asked for help here. And nothing. It truly sucks.

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @foxly dude.

    Avatar of teebes
    teebes
    Participant

    @teebes

    I would try poking around the related tables and look for a permissions or privacy column. Once you find it it should be pretty straight forward to update all the various photo’s settings versus going through the UI one by one. Good luck!

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @teebes thanks for the suggestion. I’ll dig around and try to find something like that.

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @teebes couldn’t find what you were talking about, but that doesn’t mean it’s not there. I’m going to cry. This really sucks. @foxly

    Avatar of teebes
    teebes
    Participant

    @teebes

    @zkwc I just installed the album to poke around; there is a table called wp_bp_album that contains a row for each picture. There is a privacy column that defines it’s visibility (via a numerical format, 0 == public, 4 == friends, etc). Do you really want ALL of your sitewide Album images to be public??? If so, try something like this: update wp_bp_album set privacy=’0′

    Note, take a table backup and try running this against a single image at a time (by adding a: where id=”).

    Good luck!

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @teebes thank you very much for this information.
    I found the wp_bp_album… but I’m going to wait until I have someone who knows what they are doing inside a database to do it for me. I don’t want to mess anything up, more so than it already is.

    @foxly @francescolaffi – i deactivated ALL plug-ins AGAIN except for buddypress and bpAlbum tonight since all images are private again already… same error. so i’m not having a plug-in conflict. is something a mess with buddy activity streams? Can you please check out what is happening? I can’t be the only person experiencing this. And I don’t wish this upon anyone. It is a lot of work. I’ve been playing investigation wondering why my images are doing this since November 15. All I want for Christmas is a working image album. I think you need to witness what the plug-in is doing. I’d be happy to give you access to my site. please email me zkwc / at / me / com

    Avatar of foxly
    foxly
    Participant

    @foxly

    @ZKWC

    Oh you poor thing!

    buddypress.org disabled all site emails and PM’s due to spammers. When you @tag us in a forum post, it only adds it to our “recent activity”. It doesn’t message us or anything.

    If it was an emergency you should have sent me an email. My email address is posted on my profile, and on our Google Code site.

    $a = “CarlRoett”;
    $b = “@”;
    $c = “gmail.com”;
    $email = $a . $b . $c;

    There is no need to spend all day changing images. I can fix your site with one SQL command.

    Contact me directly by email. I will get this fixed for you within an hour.

    ^F^

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @foxly – I <img src="smileys/heart.gif" width="" height="" alt="<3" title=" you!

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @foxly will you be incorporating the SQL fix into a patched v0.1.8, so that the plugin can be used with confidence on other sites as well?

    I have noticed now that when I use the admin account to delete user accounts or links, possibly anything else, it causes this problem of changing the picture status and removing activity. It is really urgent that this is resolved as soon as possible!

    Avatar of foxly
    foxly
    Participant

    @foxly

    @khore
    @rogercoathup

    This maintenance release corrects ALL problems mentioned in this thread. We will be releasing it through the WordPress SVN after more users have tested it, but in the meantime you can download it directly from our Google Code site.

    [REMOVED]

    ^F^

    Thank you foxly! I really appreciate that! It’s an excellent plugin and I look forward to keeping track of your work! I’ll let you know if there are any problems with the patch.

    Avatar of foxly
    foxly
    Participant

    @foxly

    @khore
    @rogercoathup

    Updated maintenance release to fix “Error on single image page when activity stream disabled” defect.

    http://code.google.com/p/buddypress-media/downloads/detail?name=bp-album-0.1.8.6-2010-12-17.zip

    ^F^

    Avatar of zkwc
    zkwc
    Participant

    @zkwc

    @foxly Thanks for fixing this! It totally works now. So far so good. No glitches! Great Christmas prezzy!

    Avatar of foxly
    foxly
    Participant

    @foxly

    @ZKWC

    Thanks right back for letting us test our code on your production site. It’s awesome knowing everything runs properly (and fast) on a site with thousands of users!

    Also: I have added your feature requests to the work queue.

    ^F^

Viewing 21 replies - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.