Skip to:
Content
Pages
Categories
Search
Top
Bottom

Weird characters showing instead of avatar picture on top bar after installing 1.6 update

  • Avatar of Norman
    Norman
    Participant

    @ceric

    Hello,

    I just upgraded to version 1.6. I can see that there has been some improvements, so I am happy to see.

    Just a problem appeared that now instead of the avatar picture there is now a weird code showing, I am not sure where it is coming from, but here is a screenshot of it:

    http://ceric.org/tmp/buddypress_error.png

    Anyone have any idea how I can fix this?

    Thank you

Viewing 17 replies - 1 through 17 (of 17 total)
  • Avatar of Norman
    Norman
    Participant

    @ceric

    I should add this only happens in the front-end.
    Also in addition, it seems to be adding an extra space too:

    http://ceric.org/tmp/buddypress_error2.png

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    We’re having a hard time figuring out how to recreate this. Please can we get a link to your site, to a page on which this is broken, so we can take a look?

    Avatar of Norman
    Norman
    Participant

    @ceric

    Hi Paul,

    Sure if you go to: http://ceric.org

    And I created a user account for you username: paul and password: password

    You should be able to see.
    Norman

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    I’m guessing you have a rogue code snippet that is overriding BuddyPress’ avatar code.

    Check your theme’s functions.php file located at /wp-content/YOUR-THEME/functions.php also check /wp-content/plugins/bp-custom.php. Look for any code snippet that references avatars. Can you find any?

    Also check any BuddyPress plugins you may have.

    Avatar of Norman
    Norman
    Participant

    @ceric

    Mind you this is the Salutation theme, I am sure you would know which theme.

    I found this on functions.php:


    define('AVATAR_SIZE', 35);
    avatar size

    There is a bp-custom.php, with the following code in it:

    if ( !defined( 'BP_AVATAR_THUMB_WIDTH' ) )

    define( 'BP_AVATAR_THUMB_WIDTH', 35 ); //change this with your desired thumb width

    if ( !defined( 'BP_AVATAR_THUMB_HEIGHT' ) )

    define( 'BP_AVATAR_THUMB_HEIGHT', 35 ); //change this with your desired thumb height

    What should I do now?

    Thanks,

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    IIRC, there’s a lot of custom templating inside Salutation. ceric, are you able to switch your site over to the BP-Default theme for 1 minute – then test the admin bar again, and see if the problem is cleared or not? You can re-enable Salutation right after.

    Avatar of Norman
    Norman
    Participant

    @ceric

    Indeed switching to the BP default template does not show the issue. I would think that since salutation is one popular theme for buddypress you would want BP 1.6 to work smoothly. Any ideas how I can adjust the theme to the new BP? It was issue free with the previous version of BP 1.5. Do you think I should go after the theme makers?

    Thanks for looking over this this far.

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Yes, let’s reach out to Saluation’s authors so we can figure out who needs to fix what.

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Wait, it looks like you I need to purchase the theme before I can write them a support question. Nuts :/

    Can you do that, and point them to this discussion, too? I’m happy to talk to them directly and work with them to understand the issue. We’re keen to know if it’s a theme-specific bug or something we broke in BuddyPress 1.6. Thanks for your help.

    I have this same problem and with some salution’s themas
    one on is live pls look http://www.ertmito.eu/uzytkownicy/
    also finde with avatar on bbpress forums
    what is going on ?? on 1.5.7 bp-press all work perfekt
    need fast solution pls

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    It’s a bug made by a change in 1.6; we are sorry, and we’ll fix it soon. Keep an eye on http://buddypress.trac.wordpress.org/ticket/4215

    Avatar of Norman
    Norman
    Participant

    @ceric

    I am confused. Is this fixed now on the ticket?

    http://buddypress.trac.wordpress.org/ticket/4215

    Something for me to do?:

    “Syntax that is being used seems to be: ‘html’ => ‘false'”

    Avatar of Norman
    Norman
    Participant

    @ceric

    Posted the same problem in the salutation help thread:

    http://para.llel.us/support/groups/salutation-wordpress/forum/topic/weird-characters-showing-instead-of-avatar-after-upgrading-to-buddypress-1-6/

    If I know something, I will update here too.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @ceric you can apply the fix to your installation if you’re up to it.

    Open up wp-content/plugins/buddypress/bp-core/bp-core-avatars.php and make the changes per http://buddypress.trac.wordpress.org/changeset/6247

    Remove the line/s highlighted in pink and add the line highlighted in light green.

    Save file.

    Avatar of Norman
    Norman
    Participant

    @ceric

    I went there and the file I found has the lines applied already.

    I have an update from Parallelus (author of Salutation theme), they are telling me this has to do with the fact I need up update the theme to the newest version. I am using version Version 1.4.3.1 and they released version v1.5.1. On the change log, they list:

    2012-08-07 – Update (v1.5.1)



    Fixed the HTML title element, not showing on home page
    – Updated files:
    header-default.php
    framework/theme-functions/filters-and-actions.php

    Fix for BP avatars on WP post comments
    – Updated files:
    comments.php

    BP admin bar style updates for skins
    – Updated files:
    style-default.css
    style-skin-1.css
    style-skin-2.css
    style-skin-3.css
    assets/images/icons/admin-bar-sprite.png

    Forgot a couple things in the last change log :)
    – Updated files:
    change log.txt

    2012-08-06 – Various updates (v1.5)



    BuddyPress v1.6 compatibility updates
    – Updated files:
    activity/entry.php
    activity/post-form.php
    blogs/blogs-loop.php
    groups/groups-loop.php
    groups/single/forum/topic.php
    forums/forums-loop.php
    members/members-loop.php
    members/single/member-header.php
    members/single/member-header.php
    members/single/messages/messages-loop.php
    members/single/messages/single.php
    assets/css/buddypress.css
    assets/css/source/buddypress.css
    framework/theme-functions/buddypress.php
    framework/data/example-bp-custom.php
    style-default.css
    style-skin-1.css
    style-skin-2.css
    style-skin-3.css
    comments.php

    Fixed a typo reference to “header” in the footer background.
    – Updated files:
    framework/layout-settings/admin-options-footer.php

    Modified the title elemen for better SEO plugin compatability.
    – Updated files:
    header-default.php

    Removed redundant call to duplicate function
    – Updated files:
    framework/theme-functions/buddypress.php

    Fixed BP forum reply textarea height.
    – Updated files:
    assets/css/source/buddypress.css
    assets/css/buddypress.css

    Removed duplicate ‘ago’ in groups loop
    – Updated files:
    groups/groups-loop.php

    Fixed tag not being recognized in posts
    – Updated files:
    template-blog.php

    Fixed field height bug in contact form
    – Updated files:
    framework/theme-functions/layout-and-design.php

    Updated group moderator and admin in BP headers to show “fullname” instead of “nice_name”.
    – Done to match BP default theme which also made this switch in a recent release.
    – Updated files:
    groups/single/group-header.php

    I have not yet, apply the new version of the theme, but once I do I will notify if it did fixes this issue.

    Avatar of Norman
    Norman
    Participant

    @ceric

    Note from Parallelus:

    “Note that there is likely to be a 1.5.2 theme update uploaded to ThemeForest later today.”

    Avatar of Norman
    Norman
    Participant

    @ceric

    Update, the problem does solve when you update the template to the latest version. For me, it was version 1.5.1

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.